Public bug reported:

I'm trying to deploy Bionic on a MAAS node today and this is failing
with the following dependency errors in the logs.  The node in question
is booting in EFI mode with Secure Boot enabled.

curtin: Installation started. (17.1-11-ga4c9636b-0ubuntu1~16.04.1)
third party drivers not installed or necessary.
Get:1 http://archive.ubuntu.com/ubuntu bionic InRelease [235 kB]
Hit:2 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Get:3 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [65.5 kB]
Hit:4 http://archive.ubuntu.com/ubuntu bionic-security InRelease
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1016 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8526 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages [151 kB]
Fetched 9994 kB in 11s (902 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-signed-generic : Depends: linux-signed-image-generic (= 4.15.0.10.11) 
but it is not going to be installed
                        Depends: linux-headers-generic (= 4.15.0.10.11) but it 
is not going to be installed
E: Unable to correct problems, you have held broken packages.
Unexpected error while running command.
Command: ['unshare', '--fork', '--pid', '--', 'chroot', 
'/tmp/tmp64l_1ty8/target', 'eatmydata', 'apt-get', '--quiet', '--assume-yes', 
'--option=Dpkg::options::=--force-unsafe-io', 
'--option=Dpkg::Options::=--force-confold', 'install', 'linux-signed-generic']
Exit code: 100
Reason: -
Stdout: ''
Stderr: ''
curtin: Installation failed with exception: Unexpected error while running 
command.
Command: ['curtin', 'curthooks']
Exit code: 3
Reason: -
Stdout: Get:1 http://archive.ubuntu.com/ubuntu bionic InRelease [235 kB]
        Hit:2 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
        Get:3 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [65.5 
kB]
        Hit:4 http://archive.ubuntu.com/ubuntu bionic-security InRelease
        Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1016 
kB]
        Get:6 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages 
[8526 kB]
        Get:7 http://archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages 
[151 kB]
        Fetched 9994 kB in 11s (902 kB/s)
        Reading package lists...
        Reading package lists...
        Building dependency tree...
        Reading state information...
        Some packages could not be installed. This may mean that you have
        requested an impossible situation or if you are using the unstable
        distribution that some required packages have not yet been created
        or been moved out of Incoming.
        The following information may help to resolve the situation:
        
        The following packages have unmet dependencies:
         linux-signed-generic : Depends: linux-signed-image-generic (= 
4.15.0.10.11) but it is not going to be installed
                                Depends: linux-headers-generic (= 4.15.0.10.11) 
but it is not going to be installed
        E: Unable to correct problems, you have held broken packages.
        Unexpected error while running command.
        Command: ['unshare', '--fork', '--pid', '--', 'chroot', 
'/tmp/tmp64l_1ty8/target', 'eatmydata', 'apt-get', '--quiet', '--assume-yes', 
'--option=Dpkg::options::=--force-unsafe-io', 
'--option=Dpkg::Options::=--force-confold', 'install', 'linux-signed-generic']
        Exit code: 100
        Reason: -
        Stdout: ''
        Stderr: ''
        
Stderr: ''

** Affects: linux (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: hwcert-server

** Tags added: hwcert-server

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1751111

Title:
  [Bionic] Unable to deploy BIonic via MAAS due to kernel dependency
  issues

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1751111/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to