Public bug reported:

I installed from the 17.10.1 ISO and ran into a bunch of weird issues
which may or may not be related. If I can provide any additional
information to help track down any of these, or if any of them should be
split into separate bugs, please assist me in doing the right thing.

I did an install with the default partitioning settings, without LVM or
disk encryption. At the end of the install, it informed me that grub-
install /dev/dm-0 had failed, without giving me any information at all
about the cause of the failure, and asked what I should do. At that
point I attempted to have it run grub-install /dev/sda and grub-install
/dev/sda1, the other choices that were offered, and both of them failed
as well.

After this I had to boot the live CD again, go into "try" mode instead
of "install" mode, and use Boot-Repair as described at to fix grub. This worked
fine, and I was able to boot the newly installed system afterward.

However, after doing this I discovered that some programs would not run
because they said shared libraries were not missing. This turned out to
be a more general problem than just missing shared libraries: for some
reason, many package files were missing from my hard disk. I ended up
using debsums to get a list of all missing files, pulling the package
names from that list, and reinstalling all of those packages. I have no
idea how all these files ended up missing. I didn't notice any errors
during the install which would explain it.

After this, I tried to run an ansible playbook locally that calls apt-
get install (i.e., that uses the "apt" ansible module), and this caused
ansible-playbook to consume 100% of CPU until I ctrl-C'd the ansible-
playbook process. Upon further investigation I found that the root cause
of this was that there was a line for the install cdrom left at the
beginning of /etc/apt/sources.list, which I had to remove by hand.

Overall, not a smooth install experience.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.10
ProcVersionSignature: Ubuntu 4.13.0-36.40-generic 4.13.13
Uname: Linux 4.13.0-36-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Feb 23 00:10:38 2018
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubiquity (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug artful

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  17.10.1 installer fails to run grub-install, many files missing after

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to