Hi,
Thank you for taking the time to report this bug and helping to make Ubuntu 
better.

I tried to install as well but it worked fine for me.
We need to find what is special for your case.

>From the log:
Job for tomcat8.service failed because the control process exited with error 
code. See "systemctl status tomcat8.service" and "journalctl -xe" for details.
invoke-rc.d: initscript tomcat8, action "start" failed.
● tomcat8.service - LSB: Start Tomcat.
   Loaded: loaded (/etc/init.d/tomcat8; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2018-02-23 
01:31:52 +06; 7ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 4400 ExecStart=/etc/init.d/tomcat8 start (code=exited, 
status=1/FAILURE)
Feb 23 01:31:47 mtr-tesla systemd[1]: Starting LSB: Start Tomcat....
Feb 23 01:31:47 mtr-tesla tomcat8[4400]:  * Starting Tomcat servlet engine t...8
Feb 23 01:31:52 mtr-tesla tomcat8[4400]:    ...fail!
Feb 23 01:31:52 mtr-tesla systemd[1]: tomcat8.service: Control process 
exit...=1
Feb 23 01:31:52 mtr-tesla systemd[1]: Failed to start LSB: Start 
Tomcat..
Feb 23 01:31:52 mtr-tesla systemd[1]: tomcat8.service: Unit entered 
failed ...
Feb 23 01:31:52 mtr-tesla systemd[1]: tomcat8.service: Failed with 
result '...'.


As well as:
Feb 23 01:31:52 hostname systemd[1]: Failed to start LSB: Start Tomcat..
Feb 23 01:31:52 hostname systemd[1]: tomcat8.service: Failed with result 
'exit-code'.

Unfortunately nothing points to the actual issue.
I'd recommend to start with the statement already recommended by the error 
message.

$ journalctl -xe


On upgrading a service this service has to be restarted to pick up the fixes.
Rather rarely a real issue occurs that the newer version does e.g. fail with 
the formerly working configuration.
But most of the time what happens is, that a service was installed, but stays 
unconfigured or experimented with but left in a broken state.

Now on any update of the related packages that service has to be restarted, but 
since its config is incomplete/faulty it fails to restart.
Therefore the update of that package has to consider itself incomplete.

Depending on your particular case there are two solutions:
- either remove the offending package if you don't want to continue using it.
- Or if you do want to keep it please fix the configuration so that re-starting 
the service will work.

There isn't really enough information here for a developer to confirm this 
issue is a bug, or to begin working on it.
Further since it seems likely to me that this is a local configuration problem, 
rather than a bug in Ubuntu, I'm marking this bug as Incomplete.

If indeed this is a local configuration problem, you can find pointers
to get help for this sort of problem here:
http://www.ubuntu.com/support/community

Or if you believe that this is really a bug, then you may find it
helpful to read "How to report bugs effectively"
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful
if you would then provide a more complete description of the problem,
explain why you believe this is a bug in Ubuntu rather than a problem
specific to your system, and then change the bug status back to New.

** Changed in: tomcat8 (Ubuntu)
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1751128

Title:
  package tomcat8 8.0.32-1ubuntu1.5 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/tomcat8/+bug/1751128/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to