Public bug reported:

Please remove libkolab from Bionic 18.04

Series: bionic
What: source and binaries

reverse-depends src:libkolab
Reverse-Depends
===============
* kdepim-runtime                (for libkolab1)

reverse-depends -b src:libkolab
Reverse-Build-Depends
=====================
* kdepim-runtime                (for libkolab-dev)


However, kdepim-runtime 17.12.x in -proposed no longer depends on libkolab as 
it contains and uses it's own internal port of the code.

The libkolab 1.0.2-10ubuntu9 in bionic release built against and depends
on the library versions of KDE PIM 17.08.x which we wish to replace with
17.12.x currently in proposed.

To allow this transition libkolab requires to be rebuilt against each
PIM major version and it's libs, but for 17.12.x it now FTBFS.

It would therefore block migration of KDE PIM 17.12 suite

Circumstances are the same as in this bug from fedora

https://bugzilla.redhat.com/show_bug.cgi?id=1518800

libkolab has also seen no mainline code changes in its main branches
since 2016, and even experimental code has not been ported to qdatetime
for kdatetime.

These factors are the main reason that KDE PIM developers internalised a
ported version in their own code.

To summarize the current libkolab:

- After KDE PIM 17.12 migrates will have have no rdepends
- Will block said migration as it FTBFS without a current fix
- Is close to being dead upstream

Thanks

** Affects: libkolab (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1752998

Title:
  Please remove libkolab from bionic 18.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libkolab/+bug/1752998/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to