** Description changed:

  Running `configure` of `wxpython` fails due to
  
  ```
-     checking for GTK+ - version >= 3.0.0... Package gtk+-3.0 was not found in 
the pkg-config search path.
-     Perhaps you should add the directory containing `gtk+-3.0.pc'
-     to the PKG_CONFIG_PATH environment variable
-     No package 'gtk+-3.0' found
-     no
-     *** Could not run GTK+ test program, checking why...
-     *** The test program failed to compile or link. See the file config.log 
for the
-     *** exact error that occured. This usually means GTK+ is incorrectly 
installed.
-     configure: error:
-     The development files for GTK+ were not found. For GTK+ 2, please
-     ensure that pkg-config is in the path and that gtk+-2.0.pc is
-     installed. For GTK+ 1.2 please check that gtk-config is in the path,
-     and that the version is 1.2.3 or above. Also check that the
-     libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
-     --libs' are in the LD_LIBRARY_PATH or equivalent.
+     checking for GTK+ - version >= 3.0.0... Package gtk+-3.0 was not found in 
the pkg-config search path.
+     Perhaps you should add the directory containing `gtk+-3.0.pc'
+     to the PKG_CONFIG_PATH environment variable
+     No package 'gtk+-3.0' found
+     no
+     *** Could not run GTK+ test program, checking why...
+     *** The test program failed to compile or link. See the file config.log 
for the
+     *** exact error that occured. This usually means GTK+ is incorrectly 
installed.
+     configure: error:
+     The development files for GTK+ were not found. For GTK+ 2, please
+     ensure that pkg-config is in the path and that gtk+-2.0.pc is
+     installed. For GTK+ 1.2 please check that gtk-config is in the path,
+     and that the version is 1.2.3 or above. Also check that the
+     libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
+     --libs' are in the LD_LIBRARY_PATH or equivalent.
  ```
  
  after running `apt-get build-dep python-wxgtk-media3.0, see
  https://gitlab.com/krichter/wxpython-pypi-install/pipelines/18723512 for
  a detailed overview of Ubuntu (and Debian) versions missing the build
  dependency.
+ 
+ `libgstreamer-plugins-base1.0-dev` can be added for the same reason.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: python-wxgtk-media3.0 3.0.2.0+dfsg-5
  ProcVersionSignature: Ubuntu 4.13.0-21.24-generic 4.13.13
  Uname: Linux 4.13.0-21-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.7
  Architecture: amd64
  CurrentDesktop: X-Cinnamon
  Date: Sun Mar 11 22:00:26 2018
  JournalErrors:
-  Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] 
failed with exit code 1: Hint: You are currently not seeing messages from other 
users and the system.
-        Users in the 'systemd-journal' group can see all messages. Pass -q to
-        turn off this notice.
-  No journal files were opened due to insufficient permissions.
+  Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] 
failed with exit code 1: Hint: You are currently not seeing messages from other 
users and the system.
+        Users in the 'systemd-journal' group can see all messages. Pass -q to
+        turn off this notice.
+  No journal files were opened due to insufficient permissions.
  SourcePackage: wxpython3.0
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1755025

Title:
  add libgtk-3-dev to python-wxgtk-media3.0 build-deps

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wxpython3.0/+bug/1755025/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to