If they were compiled against libcurl.so.4 I assume they would be compiled 
against abi-4 of libcurl, right?
AFAIK the supplying of libcurl.so.4 by libcurl3 was a trick by Debian by 
keeping the same exposed symbols, which kept abi-3 and abi-4 the same.
So I'd assume even though those packages specifying a dependency on libcurl3, 
in fact they did depend on libcurl.so.4 which should no problem to be provided 
by the new libcurl4.

I see btw same ldd result on Spotify:
ldd /usr/bin/spotify | grep libcurl
        libcurl.so.4 => /usr/lib/x86_64-linux-gnu/libcurl.so.4 

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  After last updated libcurl3 on libcurl4, some apps are removed.

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to