the logs are from the removal. what should I say? not a bug if you
remove it

Removing update-notifier (3.168.1) ...
Removing update-notifier-common (3.168.1) ...
Removing update-manager (1:16.04.3) ...
Removing ubuntu-release-upgrader-gtk (1:16.04.14) ...
Removing update-manager-core (1:16.04.3) ...
dpkg: warning: while removing update-manager-core, directory 
'/var/lib/update-manager' not empty so not removed
Removing ubuntu-release-upgrader-core (1:16.04.14) ...
Removing python3-aptdaemon.gtk3widgets (1.1.1+bzr982-0ubuntu14) ...
Removing python3-aptdaemon (1.1.1+bzr982-0ubuntu14) ...
Removing python3-dbus (1.2.0-3) ...
Removing python3-distupgrade (1:16.04.14) ...
Removing python3-gi (3.20.0-0ubuntu1) ...
Removing python3-update-manager (1:16.04.3) ...
Removing python3-apt (1.1.0~beta1build1) ...
dpkg: python3.5: dependency problems, but removing anyway as you requested:
 python3 depends on python3.5 (>= 3.5.1-2~).

Removing python3.5 (3.5.2-2~16.01) ...
dpkg: python3.5-minimal: dependency problems, but removing anyway as you 
requested:
 python3-minimal depends on python3.5-minimal (>= 3.5.1-2~).

Removing python3.5-minimal (3.5.2-2~16.01) ...
Unlinking and removing bytecode for runtime python3.5
dpkg: python3: dependency problems, but removing anyway as you requested:
 python3-xkit depends on python3:any (>= 3.3.2-2~).
 python3-jwt depends on python3:any (>= 3.3.2-2~).
 python3-louis depends on python3:any (>= 3.3.2-2~).
 python3-debian depends on python3:any (>= 3.3.2-2~).
 python3-ptyprocess depends on python3:any (>= 3.3.2-2~).
 dh-python depends on python3:any (>= 3.3.2-2~).
 gnome-menus depends on python3:any (>= 3.1~).
 python3-urllib3 depends on python3:any (>= 3.3.2-2~).
 python3-requests depends on python3:any (>= 3.3.2-2~).
 python3-httplib2 depends on python3:any (>= 3.3.2-2~).
 python3-html5lib depends on python3:any (>= 3.3.2-2~).
 python3-chardet depends on python3:any (>= 3.3.2-2~).
 python3-pexpect depends on python3:any (>= 3.3.2-2~).
 python3-pyasn1 depends on python3:any (>= 3.3.2-2~).
 python3-feedparser depends on python3:any (>= 3.3.2-2~).
 python3-blinker depends on python3:any (>= 3.3.2-2~).
 python3-problem-report depends on python3:any (>= 3.3.2-2~).
 python3-defer depends on pyt
Removing python3 (3.5.1-3) ...
/var/lib/dpkg/info/python3.prerm: 5: /var/lib/dpkg/info/python3.prerm: 
py3clean: not found
dpkg: error processing package python3 (--remove):
 subprocess installed pre-removal script returned error exit status 127


** Changed in: python3-defaults (Ubuntu)
       Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1605657

Title:
  package python3 3.5.1-3 failed to install/upgrade: subprocess
  installed pre-removal script returned error exit status 127

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python3-defaults/+bug/1605657/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to