I'm adding a comment here as I have new information. I discovered a
tpm_crb-driven tpm implementation on a laptop running Bionic (ASUS
ZenBook UX360CAK). Now that I happened to test tpm2-tools on it, I
discovered that:

- tpm2_getrandom worked on it,
- tpm2_listpcrs also worked.

The /dev/tpm0 device behaves as it used to, e.g. writing a command
request sends back a response, not an echo of the request. Therefore, I
am making the following conclusions:

- tpm2-tools itself is fine,
- tpm_crb driver per se is probably fine, though there likely is a bug in linux 
kernel somewhere,
- /dev/tpm0 is still programmed the same way, by writing requests and reading 

The target hardware where things still don't work is an Intel NUC 6CAYB.

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Tools no longer work against hardware TPM device on e.g. Intel NUC's
  tpm_crb driver on recent kernels

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to