It is only a recommends in Debian intentionally, and a recommends is the 
correct dependency.
It can work without it, and adding it enhances the functionality [1].

root@b2:~# apt install virt-manager
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
[...]
 gir1.2-spiceclientglib-2.0 gir1.2-spiceclientgtk-3.0
Suggested packages:
[...]
The following NEW packages will be installed:
[...]
  gir1.2-pango-1.0 gir1.2-spiceclientglib-2.0 gir1.2-spiceclientgtk-3.0
[...]
0 upgraded, 236 newly installed, 0 to remove and 0 not upgraded.
Need to get 51.4 MB of archives.
After this operation, 226 MB of additional disk space will be used.
Do you want to continue? [Y/n]

AFAIK: --install-recommends is the default, maybe it does not work together 
with --reinstall?
This is [2] IMHO - might be a feature bug for apt to discuss there if it is 
really wanted/needed.

[1]: 
https://www.debian.org/doc/debian-policy/#binary-dependencies-depends-recommends-suggests-enhances-pre-depends
[2]: 
https://askubuntu.com/questions/409573/apt-get-install-reinstall-install-recommends-not-installing-a-recommended-pa

** Attachment added: "example install"
   
https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/1741861/+attachment/5111728/+files/forbug-1741861.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1741861

Title:
  Dependency to gir1.2-spice-client-gtk-3.0 needs to update

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/1741861/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to