I made an installer of ubuntu mate 18.04 and encountered failures in all
methods of installation, side by side or to a newly created (gparted)
ext4 partition with plenty of room and free space. It gets all the way
though almost and kicks out the same error ‘apt-install grub efi …….’  I
have a hybrid motherboard in this computer can use bios or uefi. Only
way I got any joy was with a dvd ubuntu bionic beaver method. Usb never
works  and I tried over 20 times with different methods. I even tried to
follow the ubuntu one directions to add the bootloader grub  using
copy/paste method. No good. I came to learn, after I was successful with
the ubuntu via cd that there was indeed a successful installation but it
never showed up until later when I put in the grub customizer app. So ,
I do have a working , or 2 working installations of ubuntu. The ubuntu
mate (which is my favorite DE) is not successful.  I am not any expert
so no way to know how much is my fault and if or how much is a bug or
issue with the installer. I used 3 separate methods to create the live
dvd or usb too.

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for
Windows 10

From: boun...@canonical.com <boun...@canonical.com> on behalf of uthi 
Sent: Friday, May 18, 2018 4:35:52 AM
To: johnnie...@hotmail.com
Subject: [Bug 1767703] Re: Calling 'apt-install grub-efi-amd64-signed' failed

> In ubuntu 18.04 you need to select it manually while booting up.

Yes, user can select UEFI mode or BIOS at boot time of installation, but
somehow UEFI mode installation of opensuse (thumbleweed) works fine, but
1804 is not (on same disk and machine).

Also UEFI mode installation 1804 on that machine displays "message" what
it will be "manufactered mode" (as i remembered) and incorrectly defines
(displays in partition table) all existing ext4 partition as "efi", and
cant install grub on /dev/sdf(1), but tried on /dev/sda with failure

You received this bug notification because you are subscribed to a
duplicate bug report (1770787).

  Calling 'apt-install grub-efi-amd64-signed' failed

Status in grub-installer package in Ubuntu:

Bug description:
  /plugininstall.py: Exception during installation:
  /plugininstall.py: Traceback (most recent call last):
  /plugininstall.py:   File "/usr/share/ubiquity/plugininstall.py", line 1739, 
in <module>
  /plugininstall.py:     install.run()
  /plugininstall.py:   File "/usr/share/ubiquity/plugininstall.py", line 61, in 
  /plugininstall.py:     func(self)
  /plugininstall.py:   File "/usr/share/ubiquity/plugininstall.py", line 227, 
in run
  /plugininstall.py:     self.configure_bootloader()
  /plugininstall.py:   File "/usr/share/ubiquity/plugininstall.py", line 971, 
in configure_bootloader
  /plugininstall.py:     "GrubInstaller failed with code %d" % ret)
  /plugininstall.py: ubiquity.install_misc.InstallStepError: GrubInstaller 
failed with code 1


  MBR-EFI-GPT explanations/requirements:


  Manual fix:

  also see: https://bugs.launchpad.net/ubuntu/+source/grub-




  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: ubiquity 18.04.14
  ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
  Uname: Linux 4.15.0-20-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  CasperVersion: 1.394
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Apr 28 20:39:35 2018
  InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed 
boot=casper only-ubiquity quiet splash ---
  LiveMediaBuild: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
   PATH=(custom, no user)
  SourcePackage: grub-installer
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Calling 'apt-install grub-efi-amd64-signed' failed

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to