Thank you Chris. Having first checked my backup, your post gave me the
confidence to start the upgrade. It was a complete nightmare. I thought
my system was completely borked. The upgrade (using do-release-upgrade)
froze part way through, immediately after reporting the following to the

Generating a new Secure Boot signing key:
Generating a 2048 bit RSA private key
writing new private key to '/var/lib/shim-signed/mok/MOK.priv'

Waited about an hour, but it was clear that it was stuck and it didn't
appear than anything of significance was going on. Finally, I was forced
to CTRL-C the upgrade and hope for the best. The upgrade wasn't able to
restart itself because it thought something was using apt. So, I had to
manually kill various processes that had locked apt, including the
bionic process (which was presumably the upgrade process itself?), and
was then able to get the upgrade going again... but somehow it left my
system with broken dependencies.

Also the upgrade was producing extremely confusing messages such as:

The software on this computer is up to date.
There are no upgrades available for your system. The upgrade will now be 
Do you want to start the upgrade?
Continue [yN] Details[d]
> d
No longer supported: .... ecryptfs-utils ...

What does that mean? It's completed the upgrade, and it says the
software is up-to-date (great!), but that is just after it has told me
that there are broken dependencies that can't be resolved... So, when it
says the upgrade will be cancelled, does this mean it will try to roll
back the changes to recover... and what does it mean by 'starting' the
upgrade, when it should have finished already... and what do the
responses y and n mean in this context ... and when it says that
ecryptfs-utils is no longer supported, so what? Is it planning to remove
it, which I don't want, or is it just a warning? It's completely opaque,
and ultimately you just have to choose y or n at random and hope for the
best, and then go around the loop again when the first thing you tried
results in you being presented with the same prompt after something may
or may not have changed...

I was finally able to complete the upgrade, but then had to manually
resolve the broken package dependencies. There appeared to be multiple
problems, but I fortunately tackled what appears to have been the root
cause first, which was gir1.2-freedesktop. Neither

dpkg --configure -a


apt-get -f install

worked, so I had to force remove it using

sudo dpkg --remove --force-remove-reinstreq gir1.2-freedesktop

Then I reinstalled it and the packages that were removed with it to
recover. I was finally able to boot into an upgraded system, enter my
secure boot password and ...

it worked, *including the encrypted home*. How about that for a seamless
upgrade! That was from an Ubuntu 17.10 server install, on which xubuntu-
core had been installed. Let's hope the other upgrades go a bit more
smoothly than that!

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Buggy, under-maintained, not fit for main anymore; alternatives exist

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to