Public bug reported:

I configured sssd on an Ubuntu 16.04 LTS system, and it worked just
fine.  In fact, using the same sssd.conf file (which is managed by
puppet) on un-upgraded system continues to work fine.

However, after upgrading to 18.04.1 LTS, I find that the system is
continuously forgetting who I am.  After a few commands, or a few
minutes (I'm not sure exactly how many, but around 3-5 minutes) if I try
to run sudo or whoami, it says that I am an unknown user.   for example,

whoami: cannot find name for user ID 2000: Unknown error 1432158300

if I run the id command on my username, it returns the correct results,
and whoami/sudo/other restricted commands will work again for a short
time before forgetting who I am again.

In the sssd_nss.log file, I see the lookup against the @local domain,
but I do not see a related lookup in the ldap domain either in that log
file or in the log file specific to the ldap domain.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: sssd 1.16.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
Uname: Linux 4.15.0-42-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
Date: Thu Dec  6 12:30:43 2018
Ec2AMI: ami-ea677d80
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: us-east-1c
Ec2InstanceType: t2.small
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
SourcePackage: sssd
UpgradeStatus: Upgraded to bionic on 2018-10-04 (63 days ago)

** Affects: sssd (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug bionic ec2-images

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  after upgrading to bionic, my session forgets who I am frequently

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to