Hi. I'm running Mint-19.0 Tara, based largely on Ubuntu debs. I can confirm the 
bug. 1st time, it takes 3-4 seconds. It's a fresh install, duly updated & 
upgraded. I tried running it from a terminal, and got this: 
------------
dec@RoseViolet:~$ invesalius3
/usr/share/invesalius/invesalius/data/transformations.py:1899: UserWarning: 
failed to import module _transformations
  warnings.warn("failed to import module %s" % name)
session mode:  0

(app.py:1638): Gtk-CRITICAL **: 10:54:57.255: gtk_widget_set_size_request: 
assertion 'width >= -1' failed
Segmentation fault
------------

Looking at that transformations.py, the offending routine is below:
-----------
def _import_module(name, package=None, warn=True, prefix='_py_', ignore='_'):
    """Try import all public attributes from module into global namespace.

    Existing attributes with name clashes are renamed with prefix.
    Attributes starting with underscore are ignored by default.

    Return True on successful import.

    """
    import warnings
    from importlib import import_module
    try:
        if not package:
            module = import_module(name)
        else:
            module = import_module('.' + name, package=package)
    except ImportError:
        if warn:
1899 ===>>>            warnings.warn("failed to import module %s" % name)   
<<<=== 1899
    else:
        for attr in dir(module):
            if ignore and attr.startswith(ignore):
                continue
            if prefix:
                if attr in globals():
                    globals()[prefix + attr] = globals()[attr]
                elif warn:
                    warnings.warn("no Python implementation of " + attr)
            globals()[attr] = getattr(module, attr)
        return True
-------------
I'm no python expert, but I gather it's a dependency issue. I also tried the 
debian .deb, but got exactly the same fault(segfault after 3-4 seconds). It's a 
pity, it's a well recommended piece of kit. As I was trying packages, I did a 
'purge' on each one followed by an 'autoremove'. I have a few VMs (Mint, Vista, 
W10), but because there's a fault noted in W64 (app.py, line 146) I'm not 
tempted to try a windows version.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1770595

Title:
  Invesalius crashes at startup @ Ubuntu 18.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/invesalius/+bug/1770595/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to