Public bug reported:

Distributor ID: Ubuntu
Description:    Ubuntu Disco Dingo (development branch)
Release:        19.04
Codename:       disco

Long description:
I installed Xubuntu on an VM using LVM.  Download updates while installing was 
unchecked in one try, checked in the next try.  Also checked and unchecked 
Download third party drives.  No effect.  After reboot, Follow these steps to 
recreate:

1.  close update manager
2.  open terminal.
3.  sudo apt update && sudo apt upgrade
4.  During upgrade it will suggest apt autoremove to get automatically instlled 
packages that are not neeed.
5.  sudo apt autoremove.
6.  type y


What happens:
lvm2 and dependencies are removed.  While this does not break the install 
fully, re-installation throws errors.  And all restarts from then on, will give 
system errors, but still work.  Updates also work.

I would expect apt not to recommend removing lvm tools while running from an LV.
marking the lvm2 package as manually installed(used apt install lvm2) prevents 
the message and keeps it out of autoremove.

This did not happen with standard ubuntu.  Only Xubuntu

** Affects: ubuntu
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1815410

Title:
  Dingo(19.04) says LVM2 not needed when installed on an LV

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1815410/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to