** Description changed:

  Steps to reproduce
  
  1. setup a virtual machine with GPU pass-through to a nvidia Quadro card
  (nvidia only supports passthrough to Quadro cards). Nvidia also
  recommends that the passed-through card has its ROM disabled in VM
  configuration, i.e. <rom bar='off'/> . Attached an example of such VM.
  
  2. install vanilla Xubuntu 18.04, do not enable auto-login
  
  3. install nvidia drivers, e.g.
-   $ sudo add-apt-repository ppa:graphics-drivers/ppa 
-   $ sudo apt-get install nvidia-driver-410
+   $ sudo add-apt-repository ppa:graphics-drivers/ppa
+   $ sudo apt-get install nvidia-driver-410
  
- 4. reboot (due to lack of GPU ROM, the screen will be black until the
- greeter appears)
+ 4. reboot (the screen may be black until the greeter appears)
  
  5. login
  
  6. lock the screen back to the greeter
-   $ light-locker-command --lock
+   $ light-locker-command --lock
  
  Now you have black screen and unresponsive keyboard, and also one more file 
in /var/crash . The only way to get to the greeter again is to run (from 
another session, e.g. ssh)
-   $ sudo systemctl restart lightdm
+   $ sudo systemctl restart lightdm
  
  ... which will also kill all the sessions running under the login manger
  (including the one where we tried to lock the screen)
  
  I've found that this only happens with stock xfwm4 version 4.12 . If I
  upgrade xfwm4 to version 4.13 (from Mint) the screen lock works as
  expected, but this package is not in Ubuntu repo.
  
  So perhaps the problem is not with Xorg but with old xfwm4. I also tried
  other flavours of Ubuntu and IIRC also seen it in Lubuntu.
  
  At a stretch this could be called security vulnerability, because with
  this bug there is no way to lock the screen, hence users will always
  leave their session unlocked (or must log off)
  
  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-45.48-generic 4.15.18
  Uname: Linux 4.15.0-45-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus.0000.06.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/0000:06:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.version:
-  NVRM version: NVIDIA UNIX x86_64 Kernel Module  410.78  Sat Nov 10 22:09:04 
CST 2018
-  GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-27ubuntu1~18.04)
+  NVRM version: NVIDIA UNIX x86_64 Kernel Module  410.78  Sat Nov 10 22:09:04 
CST 2018
+  GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-27ubuntu1~18.04)
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  BootLog:
-  
+ 
  CompositorRunning: None
  Date: Mon Feb 11 09:14:54 2019
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus: nvidia, 410.78, 4.15.0-45-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
-  NVIDIA Corporation GM204GL [Quadro M5000] [10de:13f0] (rev a1) (prog-if 00 
[VGA controller])
-    Subsystem: NVIDIA Corporation GM204GL [Quadro M5000] [10de:1152]
+  NVIDIA Corporation GM204GL [Quadro M5000] [10de:13f0] (rev a1) (prog-if 00 
[VGA controller])
+    Subsystem: NVIDIA Corporation GM204GL [Quadro M5000] [10de:1152]
  InstallationDate: Installed on 2019-02-10 (0 days ago)
  InstallationMedia: Xubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  MachineType: QEMU Standard PC (Q35 + ICH9, 2009)
  ProcEnviron:
-  LANGUAGE=en_GB:en
-  TERM=xterm-256color
-  PATH=(custom, no user)
-  LANG=en_GB.UTF-8
-  SHELL=/bin/zsh
+  LANGUAGE=en_GB:en
+  TERM=xterm-256color
+  PATH=(custom, no user)
+  LANG=en_GB.UTF-8
+  SHELL=/bin/zsh
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-45-generic 
root=UUID=16524009-5b46-4f13-918c-0dee6cce40fe ro console=tty0 
console=ttyS0,115200n8
  SourcePackage: xorg
  Symptom: display
  Title: Xorg crash
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/06/2015
  dmi.bios.vendor: EFI Development Kit II / OVMF
  dmi.bios.version: 0.0.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: QEMU
  dmi.chassis.version: pc-q35-3.1
  dmi.modalias: 
dmi:bvnEFIDevelopmentKitII/OVMF:bvr0.0.0:bd02/06/2015:svnQEMU:pnStandardPC(Q35+ICH9,2009):pvrpc-q35-3.1:cvnQEMU:ct1:cvrpc-q35-3.1:
  dmi.product.name: Standard PC (Q35 + ICH9, 2009)
  dmi.product.version: pc-q35-3.1
  dmi.sys.vendor: QEMU
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.95-1~18.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.2-0ubuntu1~18.04.2
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.2-0ubuntu1~18.04.2
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1815429

Title:
  Xorg crash

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1815429/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to