Kye, could you elaborate on what you are seeing? I just tried a simple "apt 
install uwsgi-plugin-python3" on a fresh xenial container, and it worked:
root@xenial:~# apt install uwsgi-plugin-python3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libjansson4 libmatheval1 libsodium18 libzmq5 uwsgi-core
Suggested packages:
  nginx-full | cherokee | libapache2-mod-proxy-uwsgi | libapache2-mod-uwsgi | 
libapache2-mod-ruwsgi uwsgi-plugins-all uwsgi-extra python3-uwsgidecorators
The following NEW packages will be installed:
  libjansson4 libmatheval1 libsodium18 libzmq5 uwsgi-core uwsgi-plugin-python3
0 upgraded, 6 newly installed, 0 to remove and 2 not upgraded.
Need to get 73.8 kB/926 kB of archives.
After this operation, 3,295 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Setting up uwsgi-core (2.0.12-5ubuntu3.2) ...
Setting up uwsgi-plugin-python3 (2.0.12-5ubuntu3.2) ...
/var/lib/dpkg/info/uwsgi-plugin-python3.postinst: 61: [: Illegal number: 
Processing triggers for libc-bin (2.23-0ubuntu11) ...
root@xenial:~# echo $?

The comparison in line 61 is correct to be a number, because it's
counting the occurrences of /uwsgi_python3. That should always output a
number, 0 or higher.

Maybe that code changed, but now it reads:
        update-alternatives --list uwsgi 2>/dev/null \
        | grep -c '/uwsgi_python3$' | true \
      if [ "$BINARY_IS_UWSGI_ALTERNATIVE" -eq 0 ]; then <--- line 61

** Changed in: uwsgi (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  uwsgi-plugin-python3 failed to install

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to