** Description changed:

  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  
  libmuparser2v5:
    Installed: 2.2.3-6
    Candidate: 2.2.3-6
    Version table:
   *** 2.2.3-6 500
          500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf 
Packages
          100 /var/lib/dpkg/status
  
- Everytime the program crashes because of libmuparser2v5.
+ 
  In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5.
  The Rest of the program including all libs are built with GCC-7.
  This leads to ABI problems because there were major changes in the binary 
interface since GCC 7.3.
  I could solve this problem with building the package manually from the 
sources.
  
  Please rebuilt the package for armhf with GCC-7.

** Description changed:

  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  
  libmuparser2v5:
    Installed: 2.2.3-6
    Candidate: 2.2.3-6
    Version table:
   *** 2.2.3-6 500
          500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf 
Packages
          100 /var/lib/dpkg/status
  
- 
  In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5.
  The Rest of the program including all libs are built with GCC-7.
- This leads to ABI problems because there were major changes in the binary 
interface since GCC 7.3.
- I could solve this problem with building the package manually from the 
sources.
+ This leads to ABI problems because there were inconsistent in the binary 
interface since GCC 7.3.
+ I could solve this problem by building the package manually from the sources.
  
  Please rebuilt the package for armhf with GCC-7.

** Description changed:

  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  
  libmuparser2v5:
    Installed: 2.2.3-6
    Candidate: 2.2.3-6
    Version table:
   *** 2.2.3-6 500
          500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf 
Packages
          100 /var/lib/dpkg/status
  
  In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5.
- The Rest of the program including all libs are built with GCC-7.
- This leads to ABI problems because there were inconsistent in the binary 
interface since GCC 7.3.
- I could solve this problem by building the package manually from the sources.
+ But all other libs are built with GCC-7.
+ This leads to ABI problems because there were changes in the binary interface 
since GCC 7.3.
+ The problem could solved by building the package manually from the sources 
with GCC-7.
  
  Please rebuilt the package for armhf with GCC-7.

** Summary changed:

- ABI Error because package for armhf architecture were built with GCC-5
+ ABI Error because package for armhf architecture were built inconsistently

** Description changed:

  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  
  libmuparser2v5:
    Installed: 2.2.3-6
    Candidate: 2.2.3-6
    Version table:
   *** 2.2.3-6 500
          500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf 
Packages
          100 /var/lib/dpkg/status
  
  In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5.
  But all other libs are built with GCC-7.
  This leads to ABI problems because there were changes in the binary interface 
since GCC 7.3.
  The problem could solved by building the package manually from the sources 
with GCC-7.
  
- Please rebuilt the package for armhf with GCC-7.
+ Please rebuilt and deploy the package for armhf with GCC-7.

** Description changed:

  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  
  libmuparser2v5:
    Installed: 2.2.3-6
    Candidate: 2.2.3-6
    Version table:
   *** 2.2.3-6 500
          500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf 
Packages
          100 /var/lib/dpkg/status
  
  In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5.
- But all other libs are built with GCC-7.
+ But all other libs were built with GCC-7.
  This leads to ABI problems because there were changes in the binary interface 
since GCC 7.3.
  The problem could solved by building the package manually from the sources 
with GCC-7.
  
  Please rebuilt and deploy the package for armhf with GCC-7.

** Description changed:

  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  
  libmuparser2v5:
    Installed: 2.2.3-6
    Candidate: 2.2.3-6
    Version table:
   *** 2.2.3-6 500
          500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf 
Packages
          100 /var/lib/dpkg/status
  
- In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5.
- But all other libs were built with GCC-7.
- This leads to ABI problems because there were changes in the binary interface 
since GCC 7.3.
- The problem could solved by building the package manually from the sources 
with GCC-7.
+ In the dbgsyms-package for armhf it came out that the package were built with 
GCC-5. But all other libs were built with GCC-7.
+ This leads to ABI problems because there were changes in the binary interface 
since GCC 7.3. The problem could solved by building the package from the 
sources with GCC-7.
  
  Please rebuilt and deploy the package for armhf with GCC-7.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1823629

Title:
  ABI Error because package for armhf architecture were built
  inconsistently

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/muparser/+bug/1823629/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to