Hi,
after enabling that option, there were not many additional lines in dmesg. 
Asking the debugfs was not possible due to kernel-lockdown.

[    3.632200] usb 1-5.1: New USB device found, idVendor=0bda, idProduct=0153, 
bcdDevice=57.13                                                                 
                                                                                
                   [    3.632203] usb 1-5.1: New USB device strings: Mfr=1, 
Product=2, SerialNumber=3                                                       
                                                                                
                                         [    3.632205] usb 1-5.1: Product: 
USB2.0-CRW                                                                      
                                                                                
                                                               [    3.632207] 
usb 1-5.1: Manufacturer: Generic                                                
                                                                                
                                                                                
   [    3.632209] usb 1-5.1: SerialNumber: 20120926571200000                    
                                                                                
                                                                                
                     [    3.644643] usbcore: registered new interface driver 
usb-storage                                                                     
                                                                                
                                          [    3.647784] usbcore: registered 
new interface driver uas                                                        
                                                                                
                                                               [    3.650941] 
ums-realtek 1-5.1:1.0: Probe Realtek Card Reader!
[    3.650943] ums-realtek 1-5.1:1.0: USB Mass Storage device detected
[    3.656160] scsi host2: usb-storage 1-5.1:1.0
[    3.656374] usbcore: registered new interface driver ums-realtek
[...]
[    4.667215] sd 2:0:0:0: Attached scsi generic sg1 type 0
[    4.671782] sd 2:0:0:0: [sdb] Attached SCSI removable disk

When inserting cards:

[   95.427175] sd 2:0:0:0: [sdb] 31116288 512-byte logical blocks: (15.9 
GB/14.8 GiB)
[   95.437260]  sdb: sdb1
[  419.518691] sd 2:0:0:0: [sdb] 31116288 512-byte logical blocks: (15.9 
GB/14.8 GiB)
[  419.529411]  sdb: sdb1
[  887.138965] sd 2:0:0:0: [sdb] 31116288 512-byte logical blocks: (15.9 
GB/14.8 GiB)
[  887.150594]  sdb: sdb1
[ 2140.600999] sd 2:0:0:0: [sdb] 31116288 512-byte logical blocks: (15.9 
GB/14.8 GiB)
[ 2140.611660]  sdb: sdb1
[...]
[54170.761092] sd 2:0:0:0: [sdb] 31116288 512-byte logical blocks: (15.9 
GB/14.8 GiB)
[54170.771448]  sdb: sdb1

Interestingly, this time the device gave not up after half of a day. So
maybe the timeouts yesterday was more a problem with the card, although
it did respond after reboot again.

So how should we proceed? It looks like the "auto_delink_en=0" helps for
this device. I can keep this in my config file. Maybe it's a problem of
my device only, but still there is the strange thing that it never
caused any problems with the default driver.

If it also affects other devices with the same vendor/device id, maybe
the module should disable the auto_delink_en automatically. Maybe this
can be added to the unusual device config.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1838886

Title:
  New ID in ums-realtek module breaks cardreader

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1838886/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to