Public bug reported:

Autopkgtest fails on i386 due to kmod pulling in linux-image-
generic:i386 , but it does not exist anymore in Eoan.

http://autopkgtest.ubuntu.com/packages/i/initramfs-tools/eoan/i386

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/i386/i/initramfs-tools/20191009_203931_515d7@/log.gz
 :
...
Broken autopkgtest-satdep:i386 Depends on linux-image-generic:i386 < none @un H 
>
  Removing autopkgtest-satdep:i386 because I can't find linux-image-generic:i386
Done
...

Manual testing:

ubuntu@autopkgtest:/initramfs-tools-0.133ubuntu10$ sudo apt install 
initramfs-tools-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
initramfs-tools-core is already the newest version (0.133ubuntu10).
initramfs-tools-core set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 autopkgtest-satdep : Depends: linux-image-generic but it is not installable
                      Depends: qemu-system
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or 
specify a solution).
ubuntu@autopkgtest:/initramfs-tools-0.133ubuntu10$ sudo apt install kmod
Reading package lists... Done
Building dependency tree       
Reading state information... Done
kmod is already the newest version (26-1ubuntu1).
kmod set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 autopkgtest-satdep : Depends: linux-image-generic but it is not installable
                      Depends: qemu-system
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or 
specify a solution).

** Affects: initramfs-tools (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1847638

Title:
  initramfs-tools-core fails to install on i386

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1847638/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to