# containerd - vendorized dependencies

Here is an overall analysis of the vendorized deps in containerd version
1.3.1-0ubuntu1.

## Summary:

- Total of 85 vendorized deps
    + None of them has a correspondent package in main
- 18 vendorized deps without correspondent package in the archive
- 28 vendorized deps match version with packages in universe
- 13 vendorized deps with version greater than the correspondent package in
  universe
    + Those packages might need update
- 26 vendorized deps with version lower than the correspondent package in
  universe

## Dependencies

retrodep (https://github.com/release-engineering/retrodep) was used here to
define versions of vedorized deps:

$ retrodep --importpath github.com/containerd/containerd pkg/containerd-1.3.1/
github.com/containerd/containerd:?
error: not all versions identified
github.com/containerd/containerd:? github.com/BurntSushi/toml:v0.3.1
github.com/containerd/containerd:? github.com/Microsoft/go-winio:v0.4.14
github.com/containerd/containerd:? 
github.com/Microsoft/hcsshim:v0.8.7-0.20190828181915-f2dbb0cdfd46
github.com/containerd/containerd:? 
github.com/beorn7/perks:v0.0.0-0.20160804124726-4c0e84591b9a
github.com/containerd/containerd:? 
github.com/containerd/aufs:v0.0.0-0.20190114135352-f894a800659b
github.com/containerd/containerd:? 
github.com/containerd/btrfs:v0.0.0-0.20191213182901-e85a17791e3f
github.com/containerd/containerd:? 
github.com/containerd/cgroups:v0.0.0-0.20190911105653-fc51bcbe4714
github.com/containerd/containerd:? 
github.com/containerd/console:v0.0.0-0.20191202150009-53a0f1deb970
github.com/containerd/containerd:? 
github.com/containerd/continuity:v0.0.0-0.20190815145530-f2a389ac0a02
github.com/containerd/containerd:? 
github.com/containerd/cri:v1.11.1-0.20191022175917-e5dd80533063
github.com/containerd/containerd:? 
github.com/containerd/fifo:v0.0.0-0.20190816140239-bda0ff6ed73c
github.com/containerd/containerd:? 
github.com/containerd/go-cni:v0.0.0-0.20190813160227-49fbd9b210f3
github.com/containerd/containerd:? 
github.com/containerd/go-runc:v0.0.0-0.20190911140354-e029b79d8cda
github.com/containerd/containerd:? 
github.com/containerd/ttrpc:v0.0.0-0.20191018155249-012175fdb774
github.com/containerd/containerd:? 
github.com/containerd/typeurl:v0.0.0-0.20181015115603-823176321381
github.com/containerd/containerd:? 
github.com/containerd/zfs:v0.0.0-0.20190829130200-2ceb2dbb8154
github.com/containerd/containerd:? github.com/containernetworking/cni:v0.7.1
github.com/containerd/containerd:? github.com/containernetworking/plugins:v0.7.0
github.com/containerd/containerd:? github.com/coreos/go-systemd:v14
github.com/containerd/containerd:? github.com/cpuguy83/go-md2man:v1.0.10
github.com/containerd/containerd:? github.com/davecgh/go-spew:v1.1.1
github.com/containerd/containerd:? 
github.com/docker/distribution:v2.7.1-0.20190304145348-6e10631d9c8b
github.com/containerd/containerd:? 
github.com/docker/docker:v1.4.2-0.20171028090302-7c35a2418265
github.com/containerd/containerd:? 
github.com/docker/go-events:v0.0.0-0.20170721120031-9461782956ad
github.com/containerd/containerd:? 
github.com/docker/go-metrics:v0.0.0-0.20180131095841-4ea375f7759c
github.com/containerd/containerd:? github.com/docker/go-units:v0.4.0
github.com/containerd/containerd:? 
github.com/docker/spdystream:v0.0.0-0.20160310094837-449fdfce4d96
github.com/containerd/containerd:? github.com/emicklei/go-restful:v2.9.5
github.com/containerd/containerd:? github.com/godbus/dbus:v3
github.com/containerd/containerd:? github.com/gogo/googleapis:v1.2.0
github.com/containerd/containerd:? github.com/gogo/protobuf:v1.2.1
github.com/containerd/containerd:? github.com/golang/protobuf:v1.2.0
github.com/containerd/containerd:? github.com/google/go-cmp:v0.2.0
github.com/containerd/containerd:? github.com/google/gofuzz:v1.0.0
github.com/containerd/containerd:? github.com/google/uuid:v1.1.1
github.com/containerd/containerd:? 
github.com/grpc-ecosystem/go-grpc-prometheus:v1.1
github.com/containerd/containerd:? github.com/hashicorp/errwrap:v1.0.0
github.com/containerd/containerd:? github.com/hashicorp/go-multierror:v1.0.0
github.com/containerd/containerd:? github.com/hashicorp/golang-lru:v0.5.2
github.com/containerd/containerd:? github.com/imdario/mergo:v0.3.7
github.com/containerd/containerd:? github.com/json-iterator/go:v1.1.7
github.com/containerd/containerd:? 
github.com/konsorten/go-windows-terminal-sequences:v1.0.1
github.com/containerd/containerd:? 
github.com/matttproud/golang_protobuf_extensions:v1.0.0
github.com/containerd/containerd:? 
github.com/mistifyio/go-zfs:v2.1.2-0.20190413182219-f784269be439
github.com/containerd/containerd:? github.com/modern-go/concurrent:1.0.3
github.com/containerd/containerd:? github.com/modern-go/reflect2:1.0.1
github.com/containerd/containerd:? 
github.com/opencontainers/go-digest:v1.0.0-rc1.0.20190129152453-4eb64ca73402
github.com/containerd/containerd:? github.com/opencontainers/image-spec:v1.0.1
github.com/containerd/containerd:? github.com/opencontainers/runc:v1.0.0-rc9
github.com/containerd/containerd:? 
github.com/opencontainers/runtime-spec:v1.0.2-0.20190207144918-05b0f211cfcf
github.com/containerd/containerd:? github.com/opencontainers/selinux:v1.2.2
github.com/containerd/containerd:? github.com/pkg/errors:v0.8.1
github.com/containerd/containerd:? 
github.com/prometheus/client_golang:v0.9.0-pre1.0.20180203152815-9bb6ab929dcb
github.com/containerd/containerd:? 
github.com/prometheus/client_model:v0.0.0-0.20171117100541-99fa1f4be8e5
github.com/containerd/containerd:? 
github.com/prometheus/common:v0.0.0-0.20180110224958-89604d197083
github.com/containerd/containerd:? 
github.com/prometheus/procfs:v0.0.0-0.20180125143057-cb4147076ac7
github.com/containerd/containerd:? github.com/russross/blackfriday:v1.5.2
github.com/containerd/containerd:? github.com/seccomp/libseccomp-golang:v0.9.1
github.com/containerd/containerd:? github.com/sirupsen/logrus:v1.4.1
github.com/containerd/containerd:? 
github.com/syndtr/gocapability:v0.0.0-0.20180916081248-d98352740cb2
github.com/containerd/containerd:? github.com/tchap/go-patricia:v2.2.6
github.com/containerd/containerd:? github.com/urfave/cli:v1.22.0
github.com/containerd/containerd:? go.etcd.io/bbolt:v1.3.3
github.com/containerd/containerd:? go.opencensus.io:v0.22.0
github.com/containerd/containerd:? 
golang.org/x/crypto:v0.0.0-0.20191011191535-87dc89f01550
github.com/containerd/containerd:? 
golang.org/x/net:v0.0.0-0.20190607172144-d5cec3884524
github.com/containerd/containerd:? 
golang.org/x/oauth2:v0.0.0-0.20191122200657-5d9234df094c
github.com/containerd/containerd:? 
golang.org/x/sync:v0.0.0-0.20181108010431-42b317875d0f
github.com/containerd/containerd:? 
golang.org/x/sys:v0.0.0-0.20190812073006-9eafafc0a87e
github.com/containerd/containerd:? 
golang.org/x/text:v0.0.0-0.20170914090003-d7fd718a56d4
github.com/containerd/containerd:? 
golang.org/x/time:v0.0.0-0.20190308202827-9d24e82272b4
github.com/containerd/containerd:? 
google.golang.org/genproto:v0.0.0-0.20170523143604-d80a6e20e776
github.com/containerd/containerd:? google.golang.org/grpc:v1.23.0
github.com/containerd/containerd:? gopkg.in/inf.v0:v0.9.0
github.com/containerd/containerd:? gopkg.in/yaml.v2:v2.2.2
github.com/containerd/containerd:? gotest.tools:v2.3.0
github.com/containerd/containerd:? 
k8s.io/api:v0.0.0-0.20191003000015-cb7008132b02
github.com/containerd/containerd:? 
k8s.io/apimachinery:v0.0.0-0.20190913080033-27d36303b655
github.com/containerd/containerd:? 
k8s.io/apiserver:v0.0.0-0.20190913201147-5669a5603d96
github.com/containerd/containerd:? 
k8s.io/client-go:v0.0.0-0.20190913200447-5ff489491ea7
github.com/containerd/containerd:? k8s.io/cri-api:v0.16.4
github.com/containerd/containerd:? k8s.io/klog:v0.4.0
github.com/containerd/containerd:? k8s.io/kubernetes:v1.16.0
github.com/containerd/containerd:? 
k8s.io/utils:v0.0.0-0.20190528170020-83c61c68a349
github.com/containerd/containerd:? sigs.k8s.io/yaml:v1.1.0

## Details per dependency

Each of these dependencies were obtained from upstream vendor.conf file in 
containerd
source package version 1.3.1-0ubuntu1:

* github.com/containerd/go-runc e029b79d8cda8374981c64eba71f28ec38e5526f
    -> package needs update
    -> diff: https://github.com/containerd/go-runc/compare/4f6e87...e029b7

        golang-github-containerd-go-runc-dev | 0.0~git20180125.4f6e87a-1
| focal/universe | all

* github.com/containerd/console 0650fd9eeb50bab4fc99dceb9f2e14cf58f36e7f
    -> package needs update
    -> diff: https://github.com/containerd/console/compare/84eeaa...0650fd

        golang-github-containerd-console-dev | 0.0~git20170925.84eeaae-1
| focal/universe | all

* github.com/containerd/cgroups c4b9ac5c7601384c965b9646fc515884e091ebb9
    -> versions match

        golang-github-containerd-cgroups-dev | 0.0~git20190717.c4b9ac5-2
| focal/universe  | all

* github.com/containerd/typeurl a93fcdb778cd272c6e9b3028b2f42d813e785d40
    -> package needs update
    -> diff: https://github.com/containerd/typeurl/compare/f69435...a93fcd

        golang-github-containerd-typeurl-dev | 0.0~git20170912.f694355-1
| focal/universe | all

* github.com/containerd/fifo bda0ff6ed73c67bfb5e62bc9c697f146b7fd7f13
    -> versions match
    -> diff: https://github.com/containerd/fifo/compare/fbfb6a...bda0ff

        golang-github-containerd-fifo-dev | 0.0~git20190816.bda0ff6-2 |
focal/universe | all

* github.com/containerd/btrfs af5082808c833de0e79c1e72eea9fea239364877
    -> package needs update
    -> diff: https://github.com/containerd/btrfs/compare/2e1aa0...af5082

        golang-github-containerd-btrfs-dev | 0.0~git20180306.2e1aa0d-1 |
focal/universe | all

* github.com/containerd/continuity f2a389ac0a02ce21c09edd7344677a601970f41c
    -> package in the archive is newer (proposed)
    -> diff: https://github.com/containerd/continuity/compare/f2a389...75bee3

        golang-github-containerd-continuity-dev | 0.0~git20180216.d8fb858-1 | 
focal/universe          | all
        golang-github-containerd-continuity-dev | 0.0~git20190827.75bee3e-1 | 
focal-proposed/universe | all

* github.com/coreos/go-systemd 48702e0da86bd25e76cfef347e2adeb434a0d0a6
    -> package version in the archive is newer
    -> diff: https://github.com/coreos/go-systemd/compare/48702e...v22.0.0

        golang-github-coreos-go-systemd-dev | 22.0.0-1 | focal/universe
| all

* github.com/docker/go-metrics 4ea375f7759c82740c893fc030bc37088d2ec098
    -> package version in the archive is newer
    -> diff: https://github.com/docker/go-metrics/compare/4ea375...399ea8

        golang-github-docker-go-metrics-dev | 0.0~git20180209.399ea8c-1
| focal/universe  | all

* github.com/docker/go-events 9461782956ad83b30282bf90e31fa6a70c255ba9
    -> versions match

        golang-github-docker-go-events-dev | 0.0~git20170721.0.9461782-1
| focal/universe  | all

* github.com/docker/go-units v0.4.0
    -> versions match

        golang-github-docker-go-units-dev | 0.4.0-3
| focal/universe  | all

* github.com/godbus/dbus c7fdd8b5cd55e87b4e1f4e372cdb1db61dd6c66f
    -> package version in the archive is newer
    -> diff: https://github.com/godbus/dbus/compare/c7fdd8...v5.0.3

        golang-dbus-dev | 5.0.3-1             | focal/universe
| all

* github.com/prometheus/client_golang f4fb1b73fb099f396a7f0036bf86aa8def4ed823
    -> package version in the archive is newer
    -> diff: https://github.com/prometheus/client_golang/compare/f4fb1b...v0.9.2

        golang-github-prometheus-client-golang-dev | 0.9.2-0ubuntu3 |
focal/universe  | amd64, arm64, armhf, ppc64el, s390x

* github.com/prometheus/client_model 99fa1f4be8e564e8a6b613da7fa6f46c9edafc6c
    -> versions match

        golang-github-prometheus-client-model-dev |
0.0.2+git20171117.99fa1f4-1    | focal/universe  | all

* github.com/prometheus/common 89604d197083d4781071d3c65855d24ecfb0a563
    -> package in the archive is newer (proposed)
    -> diff: https://github.com/prometheus/common/compare/89604d...v0.7.0

        golang-github-prometheus-common-dev | 0+git20181119.b36ad28-2 | 
focal/universe          | all
        golang-github-prometheus-common-dev | 0.7.0-1                 | 
focal-proposed/universe | all

* github.com/prometheus/procfs cb4147076ac75738c9a7d279075a253c0cc5acbd
    -> package in the archive is newer
    -> diff: https://github.com/prometheus/procfs/compare/cb4147...v0.0.3

        golang-procfs-dev | 0.0.3-1                        |
focal/universe  | all

* github.com/beorn7/perks 4c0e84591b9aa9e6dcfdf3e020114cd81f89d5f9
    -> versions match

        golang-github-beorn7-perks-dev | 0.0~git20160804.0.4c0e845-1 |
focal/universe  | all

* github.com/matttproud/golang_protobuf_extensions v1.0.1
    -> versions match

        golang-protobuf-extensions-dev | 1.0.1-1                 |
focal/universe  | all

* github.com/gogo/protobuf v1.2.1
    -> package in the archive is newer
    -> diff: https://github.com/gogo/protobuf/compare/v1.2.1...dadb625

        golang-github-gogo-protobuf-dev | 1.2.1+git20190611.dadb6258-1 |
focal/universe  | all

* github.com/gogo/googleapis v1.2.0
    -> versions match

        golang-github-gogo-googleapis-dev | 1.2.0-1 | focal/universe |
all

* github.com/golang/protobuf v1.2.0
    -> package version in the archive is newer
    -> diff: https://github.com/golang/protobuf/compare/v1.2.0...v1.3.2

        golang-goprotobuf-dev | 1.3.2-2                     |
focal/universe  | amd64, arm64, armhf, i386, ppc64el, s390x

* github.com/opencontainers/runtime-spec 
29686dbc5559d93fb1ef402eeda3e35c38d75af4 # v1.0.1-59-g29686db
    -> package version in the archive is newer
    -> diff: 
https://github.com/opencontainers/runtime-spec/compare/29686d..a1b50f6

        golang-github-opencontainers-specs | 1.0.1+git20190408.a1b50f6-1
| focal/universe  | source

* github.com/opencontainers/runc d736ef14f0288d6993a1845745d6756cfc9ddd5a # 
v1.0.0-rc9
    -> pacakge needs update
    -> diff: https://github.com/opencontainers/runc/compare/3e425f8...d736ef

        golang-github-opencontainers-runc-dev |
1.0.0~rc8+git20190923.3e425f80-0ubuntu1         | focal/universe
| all

* github.com/konsorten/go-windows-terminal-sequences v1.0.1
    -> package version in the archive is newer
    -> diff: 
https://github.com/konsorten/go-windows-terminal-sequences/compare/v1.0.1...v1.0.2

        golang-github-konsorten-go-windows-terminal-sequences-dev |
1.0.2-2 | focal/universe | all

* github.com/sirupsen/logrus v1.4.1
    -> package version in the archive is newer (proposed)
    -> diff: https://github.com/sirupsen/logrus/compare/v1.4.1...v1.4.2

        golang-github-sirupsen-logrus-dev | 1.3.0-1 | focal/universe  | all
        golang-github-sirupsen-logrus-dev | 1.4.2-1 | focal-proposed/universe | 
all

* github.com/urfave/cli v1.22.0
    -> versions match

        golang-github-urfave-cli-dev | 1.22.2-1 | focal/universe  | all

* golang.org/x/net f3200d17e092c607f615320ecaad13d87ad9a2b3
    -> package version in the archive is newer (proposed)
    -> diff: https://github.com/golang/net/compare/f3200d...2180ae

        golang-golang-x-net-dev | 1:0.0+git20190811.74dc4d7+dfsg-1 | 
focal/universe          | source, all
        golang-golang-x-net-dev | 1:0.0+git20191112.2180aed+dfsg-1 | 
focal-proposed/universe | source
        golang-golang-x-net-dev | 1:0.0+git20191112.2180aed+dfsg-3 | 
focal-proposed/universe | all

* google.golang.org/grpc 6eaf6f47437a6b4e2153a190160ef39a92c7eceb # v1.23.0
    -> package needs update
    -> diff: https://github.com/grpc/grpc-go/compare/v1.22.1...v1.23.0

        golang-google-grpc-dev | 1.22.1-1ubuntu1             |
focal/universe          | all

* github.com/pkg/errors v0.8.1
    -> versions match

        golang-github-pkg-errors-dev | 0.8.1-1                       |
focal/universe  | all

* github.com/opencontainers/go-digest c9281466c8b2f606084ac71339773efd177436e7
    -> package needs update
    -> diff: 
https://github.com/opencontainers/go-digest/compare/v1.0.0-rc1...c92814

        golang-github-opencontainers-go-digest-dev | 1.0.0~rc1-1 |
focal/universe  | all

* golang.org/x/sys 9eafafc0a87e0fd0aeeba439a4573537970c44c7 
https://github.com/golang/sys
    -> package needs update
    -> diff: https://github.com/golang/sys/compare/fc99dfb...9eafafc

        golang-golang-x-sys-dev | 0.0~git20190726.fc99dfb-1ubuntu2 |
focal/universe  | all

* github.com/opencontainers/image-spec v1.0.1
    -> versions match

        golang-github-opencontainers-image-spec-dev | 1.0.1-3 |
focal/universe  | all

* golang.org/x/sync 42b317875d0fa942474b76e1b46a6060d720ae6e
    -> package version in the archive is newer
    -> diff: https://github.com/golang/sync/compare/42b317...112230

        golang-golang-x-sync-dev | 0.0~git20190423.1122301-1 |
focal/universe  | all

* github.com/BurntSushi/toml v0.3.1
    -> versions match

        golang-github-burntsushi-toml-dev | 0.3.1-1
| focal/universe  | all

* github.com/grpc-ecosystem/go-grpc-prometheus 
6b7015e65d366bf3f19b2b2a000a831940f0f7e0
    -> package version in the archive is newer
    -> diff: 
https://github.com/grpc-ecosystem/go-grpc-prometheus/compare/6b7015...6af20e

        golang-github-grpc-ecosystem-go-grpc-prometheus-dev |
1.2.0+git20191002.6af20e3-2 | focal/universe  | all

* github.com/Microsoft/go-winio v0.4.14
    -> Missing package
    -> Windows related dependency

* github.com/Microsoft/hcsshim 9e921883ac929bbe515b39793ece99ce3a9d7706
    -> Missing pacakge
    -> Windows related dependency

* google.golang.org/genproto d80a6e20e776b0b17a324d0ba1ab50a39c8e8944
    -> package version in the archive is newer
    -> diff: https://github.com/googleapis/go-genproto/compare/d80a6e...fa694d

        golang-google-genproto-dev | 0.0~git20190801.fa694d8-2build4 |
focal/universe  | all

* golang.org/x/text 19e51611da83d6be54ddafce4a4af510cb3e9ea4
    -> package version in the archive is newer
    -> diff: https://github.com/golang/text/compare/19e516...v0.3.2

        golang-x-text-dev | 0.3.2-1                            |
focal/universe  | all

* github.com/containerd/ttrpc 92c8520ef9f86600c650dd540266a007bf03670f
    -> Missing package

* github.com/syndtr/gocapability d98352740cb2c55f81556b63d4a1ec64c5a319c2
    -> versions match

        golang-gocapability-dev | 0.0+git20180916.d983527-1
| focal/universe          | source, all

* gotest.tools v2.3.0
    -> versions match

        golang-github-gotestyourself-gotest.tools-dev | 2.3.0-2 |
focal/universe | all

* github.com/google/go-cmp v0.2.0
    -> package version in the archive is newer
    -> diff: https://github.com/google/go-cmp/compare/v0.2.0...v0.3.1

        golang-github-google-go-cmp-dev | 0.3.1-1 | focal/universe  |
all

* go.etcd.io/bbolt v1.3.3
    -> Missing package
    -> Alternative package? golang-github-coreos-bbolt-dev

* github.com/hashicorp/errwrap v1.0.0
    -> versions match

        golang-github-hashicorp-errwrap-dev | 1.0.0-1
| focal/universe  | all

* github.com/hashicorp/go-multierror v1.0.0
    -> versions match

        golang-github-hashicorp-go-multierror-dev | 1.0.0-1
| focal/universe  | all

* github.com/hashicorp/golang-lru v0.5.3
    -> versions match

        golang-github-hashicorp-golang-lru-dev | 0.5.0-1                     | 
focal/universe  | all
        golang-github-hashicorp-golang-lru-dev | 0.5.3-1                     | 
focal-proposed/universe | all

* go.opencensus.io v0.22.0
    -> versions match

        golang-go.opencensus-dev | 0.22.0-1 | focal/universe | all

* github.com/imdario/mergo v0.3.7
    -> package version in the archive is newer
    -> diff: https://github.com/imdario/mergo/compare/v0.3.7...v0.3.8

        golang-github-imdario-mergo-dev | 0.3.8-1 | focal/universe  |
all

* github.com/cpuguy83/go-md2man v1.0.10
    -> versions match

        golang-github-cpuguy83-go-md2man-dev | 1.0.10+ds-1
| focal/universe  | all

* github.com/russross/blackfriday v1.5.2
    -> package version in the archive is newer
    -> diff: https://github.com/russross/blackfriday/compare/v1.5.2...a925a1

        golang-github-russross-blackfriday-dev |
1.5.2+git20190616.a925a15-1 | focal/universe  | all

@@@@ cri dependencies @@@@

* github.com/containerd/cri 5d49e7e51b43e36a6b9c4386257c7d08c602237f # 
release/1.3
    -> Missing package

* github.com/containerd/go-cni 49fbd9b210f3c8ee3b7fd3cd797aabaf364627c1
    -> Missing package

* github.com/containernetworking/cni v0.7.1
    -> versions match

        golang-github-appc-cni-dev | 0.7.1-2      | focal/universe  |
all

* github.com/containernetworking/plugins v0.7.6
    -> package version in the archive is newer
    -> diff: 
https://github.com/containernetworking/plugins/compare/v0.7.6...v0.8.4

        golang-github-containernetworking-plugins | 0.8.4-1 |
focal/universe | source

* github.com/davecgh/go-spew v1.1.1
    -> versions match

        golang-github-davecgh-go-spew-dev | 1.1.1-1           | focal/universe  
        | all
        golang-github-davecgh-go-spew-dev | 1.1.1-2           | 
focal-proposed/universe | all

* github.com/docker/distribution 0d3efadf0154c2b8a4e7b6621fff9809655cc580
    -> package version in the archive is newer
    -> diff: https://github.com/docker/distribution/compare/0d3efa...v2.7.1

        golang-github-docker-distribution-dev | 2.7.1+ds2-7 |
focal/universe  | all

* github.com/docker/docker 86f080cff0914e9694068ed78d503701667c4c00
    -> Missing package (github.com/moby/moby)

* github.com/docker/spdystream 449fdfce4d962303d702fec724ef0ad181c92528
    -> package version in the archive is newer
    -> diff: https://github.com/docker/spdystream/compare/449fdf...6480d4

        golang-github-docker-spdystream-dev | 0.0~git20181023.6480d4a-1
| focal/universe  | all

* github.com/emicklei/go-restful v2.9.5
    -> package version in the archive is newer
    -> diff: https://github.com/emicklei/go-restful/compare/v2.9.5...v2.11.1

        golang-github-emicklei-go-restful-dev | 2.11.1-1 |
focal/universe  | all

* github.com/google/gofuzz v1.0.0
    -> package needs update
    -> diff: https://github.com/google/gofuzz/compare/24818f...v1.0.0

        golang-github-google-gofuzz-dev | 0.0~git20170612.24818f7-1   |
focal/universe  | all

* github.com/json-iterator/go v1.1.7
    -> package needs update
    -> diff: https://github.com/json-iterator/go/compare/1.1.4...v1.1.7

        golang-github-json-iterator-go-dev | 1.1.4-1 | focal/universe |
all

* github.com/modern-go/reflect2 1.0.1
    -> package needs update
    -> diff: https://github.com/modern-go/reflect2/compare/1.0.0...1.0.1

        golang-github-modern-go-reflect2-dev | 1.0.0-1 | focal/universe
| all

* github.com/modern-go/concurrent 1.0.3
    -> versions match

        golang-github-modern-go-concurrent-dev | 1.0.3-1 |
focal/universe | all

* github.com/opencontainers/selinux v1.2.2
    -> package version in the archive is newer
    -> diff: https://github.com/opencontainers/selinux/compare/v1.2.2...v1.3.0

        golang-github-opencontainers-selinux-dev | 1.3.0-2
| focal/universe  | all

* github.com/seccomp/libseccomp-golang v0.9.1
    -> versions match

        golang-github-seccomp-libseccomp-golang-dev | 0.9.1-1
| focal/universe  | all

* github.com/tchap/go-patricia v2.2.6
    -> versions match

        golang-github-tchap-go-patricia-dev | 2.2.6-5 | focal/universe
| all

* golang.org/x/crypto 5c40567a22f818bd14a1ea7245dad9f8ef0691aa
    -> package version in the archive is newer
    -> diff: https://github.com/golang/crypto/compare/5c4056...4def26

        golang-golang-x-crypto-dev | 1:0.0~git20190701.4def268-2   |
focal/universe  | all

* golang.org/x/oauth2 0f29369cfe4552d0e4bcddc57cc75f4d7e672a33
    -> versions match

        golang-golang-x-oauth2-dev | 0.0~git20190604.0f29369-2   |
focal/universe  | all

* golang.org/x/time 85acf8d2951cb2a3bde7632f9ff273ef0379bcbd
    -> package needs update
    -> diff: https://github.com/golang/time/compare/f51c12...85acf8

        golang-golang-x-time-dev | 0.0~git20161028.0.f51c127-2 |
focal/universe  | all

* gopkg.in/inf.v0 v0.9.0
    -> versions match

        golang-gopkg-inf.v0-dev | 0.9.0-3 | focal/universe  | all

* gopkg.in/yaml.v2 v2.2.2
    -> versions match

        golang-gopkg-yaml.v2-dev | 2.2.2-1                            |
focal/universe  | all

* k8s.io/api kubernetes-1.16.0-rc.2
    -> Missing package

* k8s.io/apimachinery kubernetes-1.16.0-rc.2
    -> Missing package

* k8s.io/apiserver kubernetes-1.16.0-rc.2
    -> Missing package

* k8s.io/cri-api kubernetes-1.16.0-rc.2
    -> Missing package

* k8s.io/client-go kubernetes-1.16.0-rc.2
    -> Missing package

* k8s.io/klog v0.4.0
    -> Missing package

* k8s.io/kubernetes v1.16.0-rc.2
    -> Missing package

* k8s.io/utils c2654d5206da6b7b6ace12841e8f359bb89b443c
    -> Missing package

* sigs.k8s.io/yaml v1.1.0
    -> Missing package

@@@@ zfs dependencies @@@@

* github.com/containerd/zfs 2ceb2dbb8154202ed1b8fd32e4ea25b491d7b251
    -> Missing package

* github.com/mistifyio/go-zfs f784269be439d704d3dfa1906f45dd848fed2beb
    -> package needs update
    -> diff: https://github.com/mistifyio/go-zfs/compare/v2.1.1...f78426

        golang-go-zfs-dev | 2.1.1-2 | focal/universe  | all

* github.com/google/uuid v1.1.1
    -> versions match

        golang-github-google-uuid-dev | 1.1.1-1 | focal/universe | all

@@@@ aufs dependencies @@@@

* github.com/containerd/aufs f894a800659b6e11c1a13084abd1712f346e349c
    -> Missing package

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1819761

Title:
  [MIR] containerd

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/containerd/+bug/1819761/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to