Thank you for the quick response.
[1] has built now and I was verifying that it fixes the reported regression in 
Bionic.
Gladly 1:2.11+dfsg-1ubuntu7.26 still is in bionic-security so we can make a 
three way comparison.


For tests I used a default uvtool created VM and added:
<domain type='kvm'>
...
  <iothreads>1</iothreads>
...
   <controller type='scsi' index='0' model='virtio-scsi'>
      <driver iothread='1'/>
   </controller>
Note: if I did not add any disk to it nothing happened so I also set one of my 
disks to:
   <target dev='sda' bus='scsi'/>


Downgrade to former version (still in -security pocket):
1:2.11+dfsg-1ubuntu7.26:
Worked and started as expected


1:2.11+dfsg-1ubuntu7.27:
oot@b:~# virsh start iothreadfail
error: Failed to start domain iothreadfail
qemu-system-x86_64: /build/qemu-v_zvmu/qemu-2.11+dfsg/util/aio-posix.c:592: 
aio_poll: Assertion `in_aio_context_home_thread(ctx)' failed.


Upgrade to the version in proposed
1:2.11+dfsg-1ubuntu7.28:
Worked and started as expected

Log of the upgrade:
root@b:~# v=1:2.11+dfsg-1ubuntu7.28; apt install qemu-system-x86=$v qemu-kvm=$v 
qemu-block-extra=$v qemu-system-common=$v qemu-utils=$v
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  samba vde2 sgabios debootstrap
The following packages will be upgraded:
  qemu-block-extra qemu-kvm qemu-system-common qemu-system-x86 qemu-utils
5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 6783 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 qemu-utils 
amd64 1:2.11+dfsg-1ubuntu7.28 [870 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 
qemu-system-common amd64 1:2.11+dfsg-1ubuntu7.28 [672 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 
qemu-block-extra amd64 1:2.11+dfsg-1ubuntu7.28 [39.6 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 qemu-kvm 
amd64 1:2.11+dfsg-1ubuntu7.28 [13.2 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 
qemu-system-x86 amd64 1:2.11+dfsg-1ubuntu7.28 [5188 kB]
Fetched 6783 kB in 2s (3931 kB/s)          
(Reading database ... 43502 files and directories currently installed.)
Preparing to unpack .../qemu-utils_1%3a2.11+dfsg-1ubuntu7.28_amd64.deb ...
Unpacking qemu-utils (1:2.11+dfsg-1ubuntu7.28) over (1:2.11+dfsg-1ubuntu7.26) 
...
Preparing to unpack .../qemu-system-common_1%3a2.11+dfsg-1ubuntu7.28_amd64.deb 
...
Unpacking qemu-system-common (1:2.11+dfsg-1ubuntu7.28) over 
(1:2.11+dfsg-1ubuntu7.26) ...
Preparing to unpack .../qemu-block-extra_1%3a2.11+dfsg-1ubuntu7.28_amd64.deb ...
Unpacking qemu-block-extra:amd64 (1:2.11+dfsg-1ubuntu7.28) over 
(1:2.11+dfsg-1ubuntu7.26) ...
Preparing to unpack .../qemu-kvm_1%3a2.11+dfsg-1ubuntu7.28_amd64.deb ...
Unpacking qemu-kvm (1:2.11+dfsg-1ubuntu7.28) over (1:2.11+dfsg-1ubuntu7.26) ...
Preparing to unpack .../qemu-system-x86_1%3a2.11+dfsg-1ubuntu7.28_amd64.deb ...
Unpacking qemu-system-x86 (1:2.11+dfsg-1ubuntu7.28) over 
(1:2.11+dfsg-1ubuntu7.26) ...
Setting up qemu-block-extra:amd64 (1:2.11+dfsg-1ubuntu7.28) ...
Setting up qemu-utils (1:2.11+dfsg-1ubuntu7.28) ...
Setting up qemu-system-common (1:2.11+dfsg-1ubuntu7.28) ...
Setting up qemu-system-x86 (1:2.11+dfsg-1ubuntu7.28) ...
Setting up qemu-kvm (1:2.11+dfsg-1ubuntu7.28) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

Marking as verified

[1]: https://launchpad.net/ubuntu/+source/qemu/1:2.11+dfsg-1ubuntu7.28

** Tags removed: verification-needed verification-needed-bionic
** Tags added: verification-done verification-done-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1885419

Title:
  QEMU crash using virtio-scsi with iothread

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1885419/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to