@gannon1

Mike, after reading more on the patch links you sent me before, it
occurred to me I might have an easier way to test the 944 while you
create the proper patch.  Namely, I followed the same procedure as
before with the headphone patch, but right before I made the new custom
kernel I just added the new candidate CORB values to the new
patch_realtek.c file in my new custom header... so basically just
modified the samsung headphone very quiet fixup (partial sample below).
While not a proper solution, I figured it might work for testing.
Unfortunately, even after rebuilding, etc, I still don't have sound.
Assuming I didn't miss anything, I am not sure why we wouldn't have the
right corb value since the 944 covered from boot to hearing sound.  I
guess I can try again with the full halt and restart process as listed
in the openbsd article...

[ALC298_FIXUP_SAMSUNG_HEADPHONE_VERY_QUIET] = {
                .type = HDA_FIXUP_VERBS,
                .v.verbs = (const struct hda_verb[]) {
                        { 0x1a, AC_VERB_SET_PIN_WIDGET_CONTROL, 0xc5 },
                        { 0x0, 0x0, 0x2a },
                        { 0x0, 0x230, 0x3 },
                        { 0x0, 0x0, 0x27 },
                        { 0x0, 0x0, 0x0 },
                        { 0x19, 0xa7c, 0x2 },
                        { 0x37, 0xb0a, 0x0 },
                        { 0x50, 0xa00, 0x11 },
                        { 0x22, 0xa16, 0x2 },
                        { 0x1, 0x19c, 0x7b },
                        { 0x70, 0x22d, 0xa },
                        { 0x47, 0xb02, 0x2a },
                        { 0x70, 0xa00, 0x11 },
                        { 0x20, 0x11, 0x9e },
                        { 0x2, 0xa58, 0x17 },
                        { 0x0, 0x330, 0x3 },
                        { 0x0, 0x0, 0x2e },
                        { 0x0, 0x0, 0x0 },
                        { 0x62, 0x802, 0x3 },
                        { 0x20, 0xa00, 0x11 },
                        { 0x32, 0xa14, 0x2 },
                        { 0x40, 0x20c, 0x2d },
                        { 0x20, 0x11, 0x9a },
                        ... (all 944 lines)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1851518

Title:
  [950SBE/951SBE, Realtek ALC298, Speaker, Internal] No sound on
  internal speakers, very very quiet on headphones

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1851518/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to