Public bug reported:

I'm using Ubuntu 20.04.2 LTS. I've installed bbmap (version
38.79+dfsg-1) through "sudo apt-get install bbmap". However, when
running " --version" or a script " -Xmx..." (I've tried
with -Xmx5g, -Xmx4g, -Xmx1g, -Xmx800m, -Xmx100m and without setting -Xmx
on a 8 gb RAM machine) I get the following error:

/usr/bin/ línea 344: /usr/share/bbmap/calcmem: No existe el archivo o 
el directorio
/usr/bin/ línea 345: setEnvironment: orden no encontrada
/usr/bin/ línea 346: parseXmx: orden no encontrada
/usr/bin/ línea 350: freeRam: orden no encontrada
java -Xmxm -Xmsm -cp /usr/share/java/bbmap.jar jgi.BBDuk --version
Invalid maximum heap size: -Xmxm
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Downloading the package, untaring it and adding the path to the
directory in the .bashrc file prompts the same error when running the
above described commands. Also, the folder /calcmem does indeed do not

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: bbmap 38.79+dfsg-1
ProcVersionSignature: Ubuntu 5.8.0-50.56~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-50-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.17
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Thu May 13 21:41:24 2021
InstallationDate: Installed on 2020-12-05 (160 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: bbmap
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: bbmap (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug focal

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  bbduk error assigning memory

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to