Public bug reported:

When I run synaptic, select Settings/Repositories, then select the
Additional Drivers tab, I see X.Org X server (Nouveau) is selected. If I
select one of the NVIDIA drivers, and click Apply Changes, I get an
error popup: Could not get lock /var/lib/dpkg/lock-frontend. It is held
by process 18471 (synaptic).

I have only one instance of synaptic. If I run “ps guax | grep 18471”,
it lists the one synaptic process. If I exit synaptic, then that process

So, it seems that synaptic won’t allow me to change the video driver
because synaptic is running!

If I run sudo lsof /var/lib/dpkg/lock-frontend, I get: 

lsof: WARNING: can't stat() fuse.portal file system /run/user/1010/doc

      Output information may be incomplete.

lsof: WARNING: can't stat() fuse.gvfsd-fuse file system

      Output information may be incomplete.


synaptic 18471 root   12uW  REG  259,5        0 112591441

So, nothing else appears to be using lock-frontend.

ProblemType: Bug
DistroRelease: Ubuntu 24.04
Package: synaptic 0.91.3build4
ProcVersionSignature: Ubuntu 6.8.0-31.31-generic 6.8.1
Uname: Linux 6.8.0-31-generic x86_64
ApportVersion: 2.28.1-0ubuntu3
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Sat May 18 22:43:07 2024
InstallationDate: Installed on 2024-05-16 (3 days ago)
InstallationMedia: Ubuntu 24.04 LTS "Noble Numbat" - Release amd64 (20240424)
SourcePackage: synaptic
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: synaptic (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug noble wayland-session

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  synaptic won't upgrade video drivers because synaptic is running

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to