I have tried building an unpatched kernel a couple different ways
including following the direction from the recommended link
(https://itsfoss.com/compile-linux-kernel/) but failed to produce a
bootable kernel. The kernel appeared to build correctly as I did not
notice any compile errors, but once installed, it failed to boot. I am
unsure how/where to check the build logs (I still have the failed
session so I can review if needed.)

Following my notes from previous successful kernel builds (to fix sound
issues on my Lenovo laptop):

*Ubuntu version:

1) install kernel build tools:

* sudo apt install libncurses-dev gawk flex bison openssl libssl-dev
dkms libelf-dev libudev-dev libpci-dev libiberty-dev autoconf git

2) clone the kernel from github and checkout (Rather large, multiple

* git clone https://github.com/torvalds/linux.git
* cd linux
* git checkout v6.xx

3) load current kernel config and change configuration then run the
following scripts/config commands:

* make olddefconfig

4) build the kernel

* make -j 16

But both the v6.8 and v6.9 kernel fail after ~10 to 15min of compiling
with this same error:

   make[1]: *** [/home/darin/kernel/linux/Makefile:1919: .] Error 2
   make: *** [Makefile:240: __sub-make] Error 2

I inspected the MakeFile at lines 240 and 1919 but failed to see
anything obvious to edit or delete.

Not sure how to proceed from here.  I am more than happy to keep trying,
but I don't want to waste anyone's time with painful remote

A side note, I did try patching just for the experience, but the provide
patch did not work with either the 6.8 or 6.9 kernel version of
exregion.c. However, the patch is clear enough to manually perform the
edit and I could manually find the lines that required updatng.

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  System crash on resume from sleep

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to