SRU:
* https://kernel.ubuntu.com/gitea/kernel/noble-linux-oem/pulls/14 (oem-6.8)
* https://lists.ubuntu.com/archives/kernel-team/2024-June/151740.html (noble)

** Description changed:

+ [SRU Justification]
+ 
+ [Impact]
+ 
+ Multiple early IPU6 platforms may not have formal MIPI DisCo data
+ embedded in ACPI, and they may confuse latter driver and fail device
+ probing:
+ 
+   ov01a10 i2c-OVTI01A0:00: can't get clock frequency
+   ov01a10 i2c-OVTI01A0:00: failed to check hwcfg: -22
+   ov01a10: probe of i2c-OVTI01A0:00 failed with error -22
+ 
+ [Fix]
+ 
+ A few commits from mainline kernel up to v6.10-rc5.
+ 
+ [Test Case]
+ 
+ Camera sensor device should then be probed correctly.
+ 
+ [Where problems could occur]
+ 
+ These fixes are based on MIPI DisCo support that is only available since
+ v6.8. For older kernels, the ipu6-drivers either has no hwcfg checking
+ implemented, or patched with DMI info to skip it.
+ 
+ [Other Info]
+ 
+ While the patches are from v6.10-rc5, only Noble and OEM-6.8 will be
+ nominated for fixing.
+ 
+ ========== original bug report ==========
+ 
  [    5.630239] ov01a10 i2c-OVTI01A0:00: can't get clock frequency
  [    5.630248] ov01a10 i2c-OVTI01A0:00: failed to check hwcfg: -22
  [    5.631760] ov01a10: probe of i2c-OVTI01A0:00 failed with error -22
  
  Supposed to be fixed in upstream v6.9 commit 5bd4edbbf920 ("ACPI: property: 
Ignore bad graph port nodes on Dell XPS 9315").
- --- 
+ ---
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu82.5
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  CRDA: N/A
  CasperMD5CheckResult: pass
  DistributionChannelDescriptor:
-  # This is the distribution channel descriptor for the OEM CDs
-  # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
-  
canonical-oem-somerville-jammy-amd64-20220425-25+jellyfish-edge-alloem-init+X34
+  # This is the distribution channel descriptor for the OEM CDs
+  # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
+  
canonical-oem-somerville-jammy-amd64-20220425-25+jellyfish-edge-alloem-init+X34
  DistroRelease: Ubuntu 22.04
  InstallationDate: Installed on 2023-10-23 (245 days ago)
  InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - 
somerville-jammy-amd64-20220425-25
  IwConfig:
-  lo        no wireless extensions.
-  
-  enxa0cec8d68afe  no wireless extensions.
+  lo        no wireless extensions.
+ 
+  enxa0cec8d68afe  no wireless extensions.
  MachineType: Dell Inc. XPS 9315
  Package: linux-oem-6.8
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-6.5.0-9024-oem 
root=UUID=739f24ca-e488-4c9b-86e1-73d3ab581bcb ro nomodeset 
automatic-oem-config quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 6.5.0-9024.25+exp.46-oem 6.5.13
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions:
-  linux-restricted-modules-6.5.0-9024-oem N/A
-  linux-backports-modules-6.5.0-9024-oem  N/A
-  linux-firmware                          20220329.git681281e4-0ubuntu3.31
+  linux-restricted-modules-6.5.0-9024-oem N/A
+  linux-backports-modules-6.5.0-9024-oem  N/A
+  linux-firmware                          20220329.git681281e4-0ubuntu3.31
  RfKill:
-  0: hci0: Bluetooth
-       Soft blocked: no
-       Hard blocked: no
+  0: hci0: Bluetooth
+   Soft blocked: no
+   Hard blocked: no
  Tags:  jammy
  Uname: Linux 6.5.0-9024-oem x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: N/A
  _MarkForUpload: True
  dmi.bios.date: 06/12/2023
  dmi.bios.release: 1.12
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.12.0
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.12.0:bd06/12/2023:br1.12:svnDellInc.:pnXPS9315:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:sku0B14:
  dmi.product.family: XPS
  dmi.product.name: XPS 9315
  dmi.product.sku: 0B14
  dmi.sys.vendor: Dell Inc.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/2070251

Title:
  failed to probe camera sensor on Dell XPS 9315: ov01a10
  i2c-OVTI01A0:00: failed to check hwcfg: -22

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/2070251/+subscriptions


-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to