Public bug reported:

After an upgrade from Ubuntu 24.04 (up to date) to Ubuntu 26.04.1 (with
do-release-upgrade) Apache fails to start with this error in the error
log (nothing in Journal):

[Mon Oct 05 00:39:15.747328 2026] [:error] [pid 18478:tid 18478] (30)Read-only 
file system: AH10082: Can't change owner of /etc/apache2/md/challenges
[Mon Oct 05 00:39:15.747426 2026] [md:error] [pid 18478:tid 18478] 
(30)Read-only file system: AH10047: setup challenges directory
AH00016: Configuration Failed

The problem seems to be that the apache2.service file shipped in Ubuntu
26.04.1 has ProtectSystem=full, but no allowances for mod_md's
scratchpad in /etc/apache2/md/challenges - even though mod_md is bundled
in the main Apache package, and the service file does allow for other
modules' scratchpad spaces (notable mod_cache_disk).

It appears that the apache2.service file is missing a
ReadWritePaths=/etc/apache2/md setting.

** Affects: apache2 (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/2169563

Title:
  Apache fails to start, with mod_md enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/2169563/+subscriptions


-- 
ubuntu-bugs mailing list
[email protected]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to