My father told me as a kid, "I can't make enough rules." That's how I feel about which BIOS settings need changing on each 64 bit machine I encounter.

I appreciated the GUI Ubuntu installer using a one-time password to change some BIOS settings. But, more BIOS settings changes from the GUI installer may needed now, in the future if possible, I guess. Many of my problems came up with "Windows 10 only" boot options, "Launch CSM" & Fastboot to be disabled, and whatever other need-to-be-disabled BIOS setting gets invented in 2018.


Changing the GUI installer to make these changes creates work for the developers, I know. My point here is that /community awareness/ of 64 bit BIOS settings/issues being slightly different from one manufacturer to another could show developers what the big issues are. Just by knowing on forums, "this is that same old issue, now with the INSERT-MAKE-MODEL..." in forums, developers could quickly see what BIOS settings the GUI installer might need to try to change, or something else.

I'm happy to move on from this topic. My contribution is to consider if "#mb64" in any such forum issues could become unofficial SOP. No need to create extra work at this point.

Raise awareness. Optimize SEO on the topic for now. The answer will come in the future. #mb64

Linux love to all, especially Paul.



On 08/06/2017 08:00 PM, ubuntu-devel-discuss-requ...@lists.ubuntu.com wrote:
Send Ubuntu-devel-discuss mailing list submissions to
        ubuntu-devel-discuss@lists.ubuntu.com

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
or, via email, send a message with subject or body 'help' to
        ubuntu-devel-discuss-requ...@lists.ubuntu.com

You can reach the person managing the list at
        ubuntu-devel-discuss-ow...@lists.ubuntu.com

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Ubuntu-devel-discuss digest..."


Today's Topics:

    1. Re: 64bit Motherboards are a minefield of config problems
       (Paul Smith)
    2. Re: 64bit Motherboards - "all work" (Jesse Steele)


----------------------------------------------------------------------

Message: 1
Date: Sat, 05 Aug 2017 09:11:27 -0400
From: Paul Smith <p...@mad-scientist.net>
To: Jesse Steele <je...@jessesteele.com>,
        ubuntu-devel-discuss@lists.ubuntu.com
Subject: Re: 64bit Motherboards are a minefield of config problems
Message-ID: <1501938687.418.97.ca...@mad-scientist.net>
Content-Type: text/plain; charset="UTF-8"

On Sat, 2017-08-05 at 08:37 +0800, Jesse Steele wrote:
Generally, installing Ubuntu on 32 bit machines has been no problem.
However, different 64 bit motherboard manufacturers have different
native BIOS settings, many of which create problems for installing and
booting to Ubuntu.
Maybe you can give some examples of what kinds of problems you mean.

I've been running GNU/Linux distributions of all types exclusively on
64bit systems for probably 15 years or more and I've NEVER found a
motherboard or BIOS that gave me any problems.  Your message sounds like
many motherboards won't work with Linux and you have to search carefully
to locate a compatible one.  That's definitely not been my experience.



------------------------------

Message: 2
Date: Sun, 6 Aug 2017 07:32:31 +0800
From: Jesse Steele <je...@jessesteele.com>
To: p...@mad-scientist.net, ubuntu-devel-discuss@lists.ubuntu.com
Subject: Re: 64bit Motherboards - "all work"
Message-ID: <9daeb345-d80a-cb88-75ba-eb9c1a7aa...@jessesteele.com>
Content-Type: text/plain; charset="utf-8"; Format="flowed"

Paul, I believe you. I tried to make it clear that it is the "settings"
and "native settings".

For example...

I have it on my ASUS Win8 notebook with no problem, my first ever.

But, an ASUS Win10 notebook required some /native/ UEFI settings to
change with a password on the install, then no problem.

A 2017 ASUS desktop motherboard would install with the same Ubuntu GNOME
16.04, but never, never boot. Even a local Taiwanese computer shop can't
get BIOS to load GRUB and their instructions were to enter BIOS every
time to boot to GRUB.

A Gigabyte motherboard with a 2015 BIOS won't boot the USB installer and
I've looked and that BIOS has no update available. /So far in my
searching, I think/ the install partition must be 4GB or less or else a
DVD. This is the first time I had this problem, still unresolved.

An Acer 64bit notebook installed it with no problem, once we figured out
Acer BIOS requires the F12 boot menu turned on as the only option to
install it from the USB.

An HP notebook had RAID set from BIOS, but no RAID utilities?even though
forums talk about it in other HP motherboards?and the only solution I
could find was to set it to AHCI, use Gparted to create the msdos file
system.

I could go on.

Every motherboard has different requirements, different BIOS settings
that need to be changed, and it's a minefield.

Many people have the same problem viz Google: "Ubuntu BIOS settings"

Paul, you seem to know how all these motherboard settings work. You
could probably do a YouTube class on it and help a lot of people, I'd
share it. There is a marketable need to look up relevant BIOS settings
by machine.

I know it works, but not out-of-box.

We don't need more work for Canonical or developers. For now, we could
use a hashtag like #mb64 in any of these endless forum discussions on
the matter to look up /by machine/.


On 08/05/2017 09:11 PM, Paul Smith wrote:
On Sat, 2017-08-05 at 08:37 +0800, Jesse Steele wrote:
Generally, installing Ubuntu on 32 bit machines has been no problem.
However, different 64 bit motherboard manufacturers have different
native BIOS settings, many of which create problems for installing and
booting to Ubuntu.
Maybe you can give some examples of what kinds of problems you mean.

I've been running GNU/Linux distributions of all types exclusively on
64bit systems for probably 15 years or more and I've NEVER found a
motherboard or BIOS that gave me any problems.  Your message sounds like
many motherboards won't work with Linux and you have to search carefully
to locate a compatible one.  That's definitely not been my experience.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20170806/16926054/attachment-0001.html>

------------------------------


-- 
Ubuntu-devel-discuss mailing list
Ubuntu-devel-discuss@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss

Reply via email to