Public bug reported:

Please sync haproxy 1.8.3-1 (main) from Debian experimental (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Backport of -x option from upstream haproxy to enable seamless
    reloading of haproxy without dropping connections.  This is enabled
    by adding
    " stats socket <stats file> expose-fd listeners
      stats bind-process 1 "
    to the global section of your haproxy config, and
    setting HAPROXY_STATS_SOCKET in the haproxy.service unit file.
    (LP: #1712925)
  * Backport of -x option from upstream haproxy to enable seamless
    reloading of haproxy without dropping connections.  This is enabled
    by adding
    " stats socket <stats file> expose-fd listeners
      stats bind-process 1 "
    to the global section of your haproxy config, and
    setting HAPROXY_STATS_SOCKET in the haproxy.service unit file.
    (LP: #1712925)

1.8 version includes this backported change, is a the current stable
haproxy version and will be mainline throughout the bionic release
cycle. It should be in the LTS version, rather than maintaining the
current delta for five years.

Changelog entries since current bionic version 1.7.9-1ubuntu2:

haproxy (1.8.3-1) experimental; urgency=medium

  * New upstream stable release.
  * Change default configuration of stats socket to support hitless
    reload.

 -- Vincent Bernat <ber...@debian.org>  Tue, 02 Jan 2018 18:48:24 +0100

haproxy (1.8.2-1) experimental; urgency=medium

  * New upstream stable release
  * Refresh patches
  * Bump Standards-Version to 4.1.2; no changes needed

 -- Apollon Oikonomopoulos <apoi...@debian.org>  Sun, 24 Dec 2017
14:28:28 +0200

haproxy (1.8.1-1) experimental; urgency=medium

  * New upstream stable release.
  * Enable PCRE JIT.
  * systemd: replace Wants/After=syslog.service with After=rsyslog.service
    (Closes: #882610)

 -- Apollon Oikonomopoulos <apoi...@debian.org>  Sun, 03 Dec 2017
23:59:03 +0200

haproxy (1.8.0-2) experimental; urgency=medium

  * Use libatomic on platforms without 64-bit atomics. Fixes FTBFS on armel,
    mips, mipsel, powerpc, powerpcspe, sh4 and m68k.
  * d/rules: use variables defined in architecture.mk and buildflags.mk
  * d/rules: drop unreachable else case.

 -- Apollon Oikonomopoulos <apoi...@debian.org>  Wed, 29 Nov 2017
01:21:40 +0200

haproxy (1.8.0-1) experimental; urgency=medium

  * New upstream stable series. Notable new features include:
    + HTTP/2 support
    + Support for multiple worker threads to allow scalability across CPUs
      (e.g. for SSL termination)
    + Seamless reloads
    + HTTP small object caching
    + Dynamic backend server configuration
    See https://www.haproxy.com/blog/whats-new-haproxy-1-8/ and
    https://www.mail-archive.com/haproxy@formilux.org/msg28004.html for more
    detailed descriptions of the new features.
  * Upload to experimental
  * Refresh all patches.
  * d/watch: switch to the 1.8.x upstream stable series
  * Bump Standards to 4.1.1
    + Switch haproxy-doc to Priority: optional from extra.
  * Bump compat to 10:
    + B-D on debhelper (>= 10)
    + Drop explicit dh-systemd dependency and invocation
    + Replace --no-restart-on-upgrade with --no-restart-after-upgrade
      --no-stop-on-upgrade to make up for DH 10 defaults.
  * B-D on libsystemd-dev and enable sd_notify() support on Linux.
  * B-D on python3-sphinx instead of python-sphinx.
  * d/rules: do not call dpkg-parsechangelog directly.
  * d/copyright: drop obsolete section.
  * Drop obsolete lintian overrides.
  * Do a full-service restart when upgrading from pre-1.8 versions and running
    under systemd, to migrate to the new process model and service type.
    + Document this in d/NEWS as well.

 -- Apollon Oikonomopoulos <apoi...@debian.org>  Tue, 28 Nov 2017
22:25:11 +0200

** Affects: haproxy (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
High Availability Team, which is subscribed to haproxy in Ubuntu.
https://bugs.launchpad.net/bugs/1748210

Title:
  Sync haproxy 1.8.3-1 (main) from Debian experimental (main)

Status in haproxy package in Ubuntu:
  New

Bug description:
  Please sync haproxy 1.8.3-1 (main) from Debian experimental (main)

  Explanation of the Ubuntu delta and why it can be dropped:
    * Backport of -x option from upstream haproxy to enable seamless
      reloading of haproxy without dropping connections.  This is enabled
      by adding
      " stats socket <stats file> expose-fd listeners
        stats bind-process 1 "
      to the global section of your haproxy config, and
      setting HAPROXY_STATS_SOCKET in the haproxy.service unit file.
      (LP: #1712925)
    * Backport of -x option from upstream haproxy to enable seamless
      reloading of haproxy without dropping connections.  This is enabled
      by adding
      " stats socket <stats file> expose-fd listeners
        stats bind-process 1 "
      to the global section of your haproxy config, and
      setting HAPROXY_STATS_SOCKET in the haproxy.service unit file.
      (LP: #1712925)

  1.8 version includes this backported change, is a the current stable
  haproxy version and will be mainline throughout the bionic release
  cycle. It should be in the LTS version, rather than maintaining the
  current delta for five years.

  Changelog entries since current bionic version 1.7.9-1ubuntu2:

  haproxy (1.8.3-1) experimental; urgency=medium

    * New upstream stable release.
    * Change default configuration of stats socket to support hitless
      reload.

   -- Vincent Bernat <ber...@debian.org>  Tue, 02 Jan 2018 18:48:24
  +0100

  haproxy (1.8.2-1) experimental; urgency=medium

    * New upstream stable release
    * Refresh patches
    * Bump Standards-Version to 4.1.2; no changes needed

   -- Apollon Oikonomopoulos <apoi...@debian.org>  Sun, 24 Dec 2017
  14:28:28 +0200

  haproxy (1.8.1-1) experimental; urgency=medium

    * New upstream stable release.
    * Enable PCRE JIT.
    * systemd: replace Wants/After=syslog.service with After=rsyslog.service
      (Closes: #882610)

   -- Apollon Oikonomopoulos <apoi...@debian.org>  Sun, 03 Dec 2017
  23:59:03 +0200

  haproxy (1.8.0-2) experimental; urgency=medium

    * Use libatomic on platforms without 64-bit atomics. Fixes FTBFS on armel,
      mips, mipsel, powerpc, powerpcspe, sh4 and m68k.
    * d/rules: use variables defined in architecture.mk and buildflags.mk
    * d/rules: drop unreachable else case.

   -- Apollon Oikonomopoulos <apoi...@debian.org>  Wed, 29 Nov 2017
  01:21:40 +0200

  haproxy (1.8.0-1) experimental; urgency=medium

    * New upstream stable series. Notable new features include:
      + HTTP/2 support
      + Support for multiple worker threads to allow scalability across CPUs
        (e.g. for SSL termination)
      + Seamless reloads
      + HTTP small object caching
      + Dynamic backend server configuration
      See https://www.haproxy.com/blog/whats-new-haproxy-1-8/ and
      https://www.mail-archive.com/haproxy@formilux.org/msg28004.html for more
      detailed descriptions of the new features.
    * Upload to experimental
    * Refresh all patches.
    * d/watch: switch to the 1.8.x upstream stable series
    * Bump Standards to 4.1.1
      + Switch haproxy-doc to Priority: optional from extra.
    * Bump compat to 10:
      + B-D on debhelper (>= 10)
      + Drop explicit dh-systemd dependency and invocation
      + Replace --no-restart-on-upgrade with --no-restart-after-upgrade
        --no-stop-on-upgrade to make up for DH 10 defaults.
    * B-D on libsystemd-dev and enable sd_notify() support on Linux.
    * B-D on python3-sphinx instead of python-sphinx.
    * d/rules: do not call dpkg-parsechangelog directly.
    * d/copyright: drop obsolete section.
    * Drop obsolete lintian overrides.
    * Do a full-service restart when upgrading from pre-1.8 versions and running
      under systemd, to migrate to the new process model and service type.
      + Document this in d/NEWS as well.

   -- Apollon Oikonomopoulos <apoi...@debian.org>  Tue, 28 Nov 2017
  22:25:11 +0200

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/haproxy/+bug/1748210/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~ubuntu-ha
Post to     : ubuntu-ha@lists.launchpad.net
Unsubscribe : https://launchpad.net/~ubuntu-ha
More help   : https://help.launchpad.net/ListHelp

Reply via email to