We found a case there installing esm packages will fail with a 401.

ubuntu-advantage-tools needs apt (and libapt-pkg4.12) at version
1.0.1ubuntu2.22 or higher, otherwise it won't recognize the
/etc/apt/auth.conf.d/90ubuntu-advantage file which is where the
credentials are stored. apt older than 1.0.1ubuntu2.22 only knows about

Adding a depends on libapt-pkg4.12 (>= 1.0.1ubuntu2.22) to the ubuntu-
advantage-tools package, perahps also on apt, should address this, but I
worry about adding apt related dependencies to a package that will
likely be upgraded in the same apt transaction. It's also something that
other ua offerings doesn't need, like livepatch.

Another possibility is to add code to ubuntu-advantage-tools to install
a newer apt if needed, when esm is enabled.

You received this bug notification because you are a member of Ubuntu
Server, which is subscribed to ubuntu-advantage-tools in Ubuntu.

  Enable support for trusty ESM

To manage notifications about this bug go to:

Ubuntu-server-bugs mailing list
Modify settings or unsubscribe at: 

Reply via email to