Michael Sheldon has proposed merging 
lp:~michael-sheldon/ubuntu-terminal-app/packaging-fixes into 
lp:ubuntu-terminal-app.

Commit message:
* Use dh_python3
* Rename QML modules to new qml-module format

Requested reviews:
  Ubuntu Terminal Developers (ubuntu-terminal-dev)

For more details, see:
https://code.launchpad.net/~michael-sheldon/ubuntu-terminal-app/packaging-fixes/+merge/306252

* Use dh_python3
* Rename QML modules to new qml-module format
-- 
Your team Ubuntu Terminal Developers is requested to review the proposed merge 
of lp:~michael-sheldon/ubuntu-terminal-app/packaging-fixes into 
lp:ubuntu-terminal-app.
=== modified file 'debian/control'
--- debian/control	2016-09-19 14:33:25 +0000
+++ debian/control	2016-09-20 17:25:18 +0000
@@ -3,6 +3,7 @@
 Maintainer: Ubuntu App Cats <ubuntu-touch-corea...@lists.launchpad.net>
 Build-Depends: cmake,
                debhelper (>= 9),
+               dh-python,
                python3-all,
                gettext,
                intltool,
@@ -20,16 +21,23 @@
 Architecture: any
 Depends: ${misc:Depends},
          ${shlibs:Depends},
+<<<<<<< TREE
          qtdeclarative5-qmltermwidget1.0,
          qtdeclarative5-pamauthentication0.1,
          qtdeclarative5-qtquick2-plugin,
          qtdeclarative5-ubuntu-ui-toolkit-plugin,
          qml-module-qt-labs-settings,
+=======
+         qml-module-qmltermwidget1.0,
+         qml-module-pamauthentication0.1,
+         qml-module-qtquick2,
+         qml-module-ubuntu-components,
+>>>>>>> MERGE-SOURCE
          qml-module-qtsysteminfo (>= 5.0~),
 Description: Terminal application
  Core Terminal application
 
-Package: qtdeclarative5-qmltermwidget1.0
+Package: qml-module-qmltermwidget1.0
 Architecture: any
 Multi-Arch: same
 Depends: ${misc:Depends},
@@ -39,7 +47,7 @@
  This package contains the QMLTermWidget terminal emulator plugin
  for Qt Qml.
 
-Package: qtdeclarative5-pamauthentication0.1
+Package: qml-module-pamauthentication0.1
 Architecture: any
 Multi-Arch: same
 Depends: ${misc:Depends},
@@ -52,6 +60,7 @@
 Package: ubuntu-terminal-app-autopilot
 Architecture: all
 Depends: ${misc:Depends},
+         ${python3:Depends},
          libautopilot-qt,
          libqt5test5,
          python3-autopilot,

=== renamed file 'debian/qtdeclarative5-pamauthentication0.1.install' => 'debian/qml-module-pamauthentication0.1.install'
=== renamed file 'debian/qtdeclarative5-qmltermwidget1.0.install' => 'debian/qml-module-qmltermwidget1.0.install'
=== modified file 'debian/rules'
--- debian/rules	2014-10-25 04:42:31 +0000
+++ debian/rules	2016-09-20 17:25:18 +0000
@@ -5,7 +5,7 @@
 #export DH_VERBOSE=1
 
 %:
-	dh $@
+	dh $@ --with python3
 
 override_dh_auto_configure:
 	dh_auto_configure -- -DCLICK_MODE=OFF

-- 
Mailing list: https://launchpad.net/~ubuntu-touch-coreapps-reviewers
Post to     : ubuntu-touch-coreapps-reviewers@lists.launchpad.net
Unsubscribe : https://launchpad.net/~ubuntu-touch-coreapps-reviewers
More help   : https://help.launchpad.net/ListHelp

Reply via email to