Viet, thank you for reporting this and helping make Ubuntu better.

Could you please provide the missing information from

** Description changed:

- I am using one screen on my laptop, one connected via hdmi directly to my 
laptop and one via iTec usb 3 dockingstation. I have Nvidia proprietary drivers 
installed but switched to the open ones, as suggested in the workaround on this 
site ( I followed 
the workaround and uninstalled displaylink drivers, rebooted, reinstalled them 
and rebooted. This worked nicely, but I wanted to use a sceen in portrait mode 
instead of landscape, so I rotated it and after this my cursor flickered and 
was followed by an werid rectangle, in which the screen doesnt update. So I 
tried reinstalling again but without success. I also tried the command xrand 
--auto, but without success. The rectangle stayed. I tried to deactivate my 
smallest screen, which was the integrated laptop screen, but the problem 
persisted. If i uninstalled die display link driver, reboot so that I only use 
the directly connected screen and my laptop screen, then everything worked 
properly with and without rotation.  Also after those driver un- and 
reinstalling the flickering would occur even without screen rotation (with 
display link driver installed).
- After some searching I stumbled upon
 which suggested logging out and then in again, which solved my problem.
+ I am using the built-in laptop screen, one external monitor connected
+ directly to my laptop via HDMI, and one external monitor connect via a
+ i-tec USB 3.0 Docking Station.
- Now I can operate 3 monitors and one beeing rotated.
+ What happens is my mouse cursor flickers and is followed by an weird
+ rectangle, in which the screen doesn't update.
+ Deactivating my laptop screen didn't change anything.
+ This is not reproducible if I only use the laptop screen and HDMI
+ connected external monitor.
+ WORKAROUND: Log out and in again.
  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: xorg 1:7.7+19ubuntu3
  ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
  Uname: Linux 4.13.0-32-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  .proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: 
  .proc.driver.nvidia.registry: Binary: ""
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.25  Wed Jan 24 20:02:43 
PST 2018
   GCC version:  gcc version 7.2.0 (Ubuntu 7.2.0-8ubuntu3)
  ApportVersion: 2.20.7-0ubuntu3.7
  Architecture: amd64
  CompizPlugins: No value set for 
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Feb 13 23:58:09 2018
  DistUpgraded: Fresh install
  DistroCodename: artful
  DistroVariant: ubuntu
   bbswitch, 0.8, 4.13.0-31-generic, x86_64: installedError! Could not locate 
dkms.conf file.
   File:  does not exist.
   bbswitch, 0.8, 4.13.0-32-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
   Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] 
(rev 09) (prog-if 00 [VGA controller])
     Subsystem: Acer Incorporated [ALI] 3rd Gen Core processor Graphics 
Controller [1025:071a]
   NVIDIA Corporation GK107M [GeForce GT 640M] [10de:0fd2] (rev a1) (prog-if 00 
[VGA controller])
     Subsystem: Acer Incorporated [ALI] GK107M [GeForce GT 640M] [1025:071b]
  InstallationDate: Installed on 2017-12-06 (69 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  MachineType: Acer Aspire M5-581TG
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-32-generic.efi.signed 
root=UUID=ac6372c5-a60f-47d5-8eab-91390b01a680 ro noplymouth
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install) 02/25/2013
  dmi.bios.vendor: Acer
  dmi.bios.version: V2.11
  dmi.board.asset.tag: Type2 - Board Asset Tag MA51_HX
  dmi.board.vendor: Acer
  dmi.board.version: Type2 - Board Version
  dmi.chassis.type: 10
  dmi.chassis.vendor: Acer
  dmi.chassis.version: V2.11
dmi:bvnAcer:bvrV2.11:bd02/25/2013:svnAcer:pnAspireM5-581TG:pvrV2.11:rvnAcer:rnMA51_HX:rvrType2-BoardVersion:cvnAcer:ct10:cvrV2.11: Type1Family Aspire M5-581TG
  dmi.product.version: V2.11
  dmi.sys.vendor: Acer
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.83-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.8-0ubuntu0~17.10.1
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.8-0ubuntu0~17.10.1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
  xserver.bootTime: Tue Feb 13 23:14:54 2018
  xserver.configfile: /etc/X11/xorg.conf
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.19.5-0ubuntu2

** Changed in: xorg (Ubuntu)
   Importance: Undecided => Low

** Changed in: xorg (Ubuntu)
       Status: New => Incomplete

** Summary changed:

- mouse started to Flicker with 3rd monitor
+ Mouse icon flickers when connected to i-tec USB 3.0 Docking Station

You received this bug notification because you are a member of Ubuntu-X,
which is subscribed to xorg in Ubuntu.

  Mouse icon flickers when connected to i-tec USB 3.0 Docking Station

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to