#29 does not seem to be correct, at least in my case. Installed xserver-
xorg-legacy first, and checked. No 'X' wrapper binary present. After
installing other xserver packages, this is what I have.

Output of ls -la /usr/bin | grep X
On 14.04:
-rwsr-sr-x  1 root   root        9532 Dec  9  2014 X
lrwxrwxrwx  1 root   root           1 Jan  3  2013 X11 -> .
-rwxr-xr-x  1 root   root     2322928 Oct 13 09:07 Xorg

On 16.04
lrwxrwxrwx  1 root   root           4 Oct 13 08:59 X -> Xorg
lrwxrwxrwx  1 root   root           1 Mar  4  2016 X11 -> .
-rwxr-xr-x  1 root   root         274 Oct 13 08:59 Xorg

No matter what I do, including trying --force-overwrite passed to dpkg,
it installs a link to Xorg, not the suid wrapper.

-- 
You received this bug notification because you are a member of Ubuntu-X,
which is subscribed to xinit in Ubuntu.
https://bugs.launchpad.net/bugs/1562219

Title:
  Unprivileged xinit wont start in unallocated vt

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xinit/+bug/1562219/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~ubuntu-x-swat
Post to     : ubuntu-x-swat@lists.launchpad.net
Unsubscribe : https://launchpad.net/~ubuntu-x-swat
More help   : https://help.launchpad.net/ListHelp

Reply via email to