Thanks Nish. Confirmed that LLDB.h is present in this package and issue
is resolved.

Tested on fresh Bionic:

```
sed -i.old '1s;^;deb-src http://ppa.launchpad.net/nacc/lp1761009/ubuntu bionic 
main\n;' /etc/apt/sources.list
sed -i.old '1s;^;deb http://ppa.launchpad.net/nacc/lp1761009/ubuntu bionic 
main\n;' /etc/apt/sources.list

cat <<EOT >> nacc-llvm-6.0-key.pgp.pub
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: SKS 1.1.6
Comment: Hostname: keyserver.ubuntu.com

mQINBFZ65eABEADBpDdmE/S5e6Sq3yqvTxZAzH28rgrENr7yI190VfL519cWGMQAG3vMS8fx
0AvghM5sRgCppFcHP76+hRcLWtYOfMfuSmGs8eNBjYCCKnjDZ8TyO/NL9/SrFzthLO4knzh7
K9Z9f4ZwucRIw5TEl7I0veinqGOEZLTN6d4n+z1aa3rq2tKgHqPD36WtXXIE3kLpwppIcZBf
1oBGbYP7B2C+kN9n1oZCcyvJnIyv61Zyeo9VrFzR9jhKdeBOSqB7M8t1CjEa0trumf9RB47F
XW0froexZFVb3F2Z7Gt8LtAOZ67NdRIA5J1Cd2/U4+m2kvGiC5YI8dQUsLhKFxwR5LNqlptU
QQMs1lkY4awTCAzXWGbRSNe43Pxet75peMuiKw5DItb9WlfHk6gU42hmg4f+XD5EigYnzcjX
sYuw3OoWb2/1qqAHZ5Z+DPYRx8eBrGQ2NkudKAzr7k9P2iczL2smQPS/OTl56IeVeUwSA6L/
SGjshwTtwNkOLgxJmrUOyX6xc6CsiIviLdurvQLIEE5cBDUkuJV4ioiw0jMCNbhZgnmUlgFE
vzuEL19G8OyePrgbn5IqjUqroyNxRF5bAGCf1AXTl7jj2e3/MbwdTuIvS7t6AILn3H5zg3EF
7Tkr+AxeURowfhnRBsjMyE2flmPddOVSm2P9EejHQUl2Tt3DrwARAQABtCFMYXVuY2hwYWQg
UFBBIGZvciBOaXNoIEFyYXZhbXVkYW6JAjgEEwECACIFAlZ65eACGwMGCwkIBwMCBhUIAgkK
CwQWAgMBAh4BAheAAAoJEMDcRaBRBcexrz8QAJAnU+Na3DE2n6dtQwuKhIDozzH+L7Ep/L7a
CBmZpu6kSjsCdJt2grZXuGSiBXG7IxZ6ia0eptT4FzuYZJAdYqetcQVCnXNK4LpfvbuZN3Zu
OApZN1xhqiGdJ6wG0MSy5tvQh7XfbwUiCvb+86TkesFavyRP3GiX0ihFaoGxDRuByZsrXf10
VNMwO7v+2Nic52cVzLtUgqjKD6y1AfmyHjWLle6Ro8B/AQOAIlhyibiur9fReQhO8/HqONVv
OyNgfpdWjfldSIOxdl8a4npspCVzr+1xl2pm0uw0rWxgtkUNhDLv0JGG9dJj2yrVePF26F4e
lLtvOFOh/rN+wuJwShNBo5F/9/fka5ilSLHZrczMoap7k0UhqqIFahcy6myOhhPnASoVi/HB
PbUGm/VyOrqBY+y+ZLEWkYDje7FOWVPR3UUWfwWZpPcgODzysp3PTZ+g/DYByn6BuSSIb6e2
BBjF3hb6Id4e3/AcAD00hu+aqIDera2tPy8ga9QnqgQ71pKIupE8+Zq8ylKo74+CVME48iER
2mOLLh9Xb4t+VRi971PgR74u34NxJwE+zfVPoaNzYAvO4Jz0tIVwj1GBoNxHTwsUOEJra7Mq
ufgEA+Ck7yM1wZ1dYqKFKWdEdIDz0RjikOwu0YZRbXlhJP45DAsa1mB1i1e0aBOtLzz2yBIQ
=eTc3
-----END PGP PUBLIC KEY BLOCK-----
EOT

apt-key add nacc-llvm-6.0-key.pgp.pub
apt update
apt install -y liblldb-6.0-dev llvm clang < /dev/null

find / -name LLDB.h
# /usr/lib/llvm-6.0/include/lldb/API/LLDB.h
ls /usr/lib/llvm-6.0/include/lldb/API
# rest of the headers are there
ls -1 /usr/lib/llvm-6.0/include/lldb/API | wc -l
# 68 (previously it was 0)

# then tried building dotnet, which wasn't building before
# (without -DENABLE_LLDBPLUGIN=0 option; libsosplugin.so in product requires 
LLDB.h)

apt install -y curl libcurl4-openssl-dev git cmake libunwind-dev
liblttng-ust-dev libicu-dev < /dev/null

git clone https://github.com/dotnet/coreclr --single-branch -b release/2.1 
--depth 1
cd coreclr
./build.sh
# succeeded
```

-- 
You received this bug notification because you are a member of Ubuntu-X,
which is subscribed to llvm-toolchain-6.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1761009

Title:
  LLDB.h is missing from liblldb-6.0-dev package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/llvm-toolchain-6.0/+bug/1761009/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~ubuntu-x-swat
Post to     : ubuntu-x-swat@lists.launchpad.net
Unsubscribe : https://launchpad.net/~ubuntu-x-swat
More help   : https://help.launchpad.net/ListHelp

Reply via email to