Thank you for reporting this bug to Ubuntu.
Ubuntu 10.10 (maverick) reached end-of-life on April 10, 2012.

See this document for currently supported Ubuntu releases: 

Please upgrade to the latest version and re-test.

** Changed in: pulseaudio (Ubuntu)
       Status: Confirmed => Incomplete

** Changed in: portaudio (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Ubuntu
Studio Bugs, which is subscribed to audacity in Ubuntu.
Matching subscriptions: Ubuntu Studio Bugs

  Audacity ruins bluetooth

Status in Audacity:
Status in audacity package in Ubuntu:
Status in portaudio package in Ubuntu:
Status in pulseaudio package in Ubuntu:

Bug description:
  Binary package hint: audacity

  Apparently Audacity is not smart enough to know that it's running
  under a Gnome environment. Everything in terms of audio devices is
  managed quite well with pulseaudio, bluetooth-applet, and other Gnome
  desktop infrastructure. It tries to hard and breaks it. It tries to
  hack into my bluetooth in a vain attempt to find a headset or
  something like that and it ruins my bluetooth support in the desktop.
  I am no longer able to send files or use bluetooth in anyway.

  First thing it does when you launch it is that it does nothing. It'll
  just hang. You click on the icon in the menu and you won't get any
  feedback. Even if you run it from the command line it will give no
  feedback and display no errors. It just hangs.

  Then you kill it and restart it a couple times and it launches successfully. 
Sorta. Besides the globalmenu bug reported in another report it displays this 
error on my terminal:
  $ audacity 
  bt_audio_service_open: connect() failed: Connection refused (111)
  bt_audio_service_open: connect() failed: Connection refused (111)
  bt_audio_service_open: connect() failed: Connection refused (111)
  bt_audio_service_open: connect() failed: Connection refused (111)
  Cannot connect to server socket err = No such file or directory
  Cannot connect to server socket
  jack server is not running or cannot be started
  Expression 'stream->capture.pcm' failed in 
'src/hostapi/alsa/pa_linux_alsa.c', line: 3653

  Here is the errors reported by dmesg:

  [  807.086761] EXT4-fs (dm-0): re-mounted. Opts: commit=0
  [  812.790151] usb 6-1: USB disconnect, address 2
  [  812.790881] btusb_intr_complete: hci0 urb ffff88010e8e1600 failed to 
resubmit (19)
  [  812.790905] btusb_bulk_complete: hci0 urb ffff88010e8e1c00 failed to 
resubmit (19)
  [  812.791892] btusb_bulk_complete: hci0 urb ffff8801185a93c0 failed to 
resubmit (19)
  [  812.792064] btusb_send_frame: hci0 urb ffff8800c0872e40 submission failed
  [  813.322598] usb 6-1: new full speed USB device using uhci_hcd and address 3
  [  900.790130] usb 6-1: USB disconnect, address 3
  [  900.790753] btusb_intr_complete: hci0 urb ffff8800cba0d6c0 failed to 
resubmit (19)
  [  900.790784] btusb_bulk_complete: hci0 urb ffff8800c0805d80 failed to 
resubmit (19)
  [  900.791836] btusb_bulk_complete: hci0 urb ffff8800c0805180 failed to 
resubmit (19)
  [  900.792039] btusb_send_frame: hci0 urb ffff8800c08ddf00 submission failed
  [  900.807505] bluetooth-apple[2004]: segfault at a ip 00007f65d520c9ee sp 
00007fffba728880 error 4 in[7f65d5208000+10000]
  [  901.320309] usb 6-1: new full speed USB device using uhci_hcd and address 4
  [ 1308.540165] usb 6-1: USB disconnect, address 4
  [ 1308.541015] btusb_intr_complete: hci0 urb ffff8800c0b18840 failed to 
resubmit (19)
  [ 1308.541045] btusb_bulk_complete: hci0 urb ffff8800c099eb40 failed to 
resubmit (19)
  [ 1308.542097] btusb_bulk_complete: hci0 urb ffff8800c0b180c0 failed to 
resubmit (19)
  [ 1308.542300] btusb_send_frame: hci0 urb ffff88010f313540 submission failed

  At that point my bluetooth support is broken and thus Audacity will
  successfully open. After hitting ctrl-f to work around the globalmenu
  bug (even though I am not using global menu) I can then edit files and
  such. Save them. Everything works.

  Of course I can no longer connect to the internet through my phone,
  send files, upload ringtones, use my bluetooth headset, etc. To work
  around you can remove the USB bluetooth adapter if you use a external
  one, plug it back in, and launch bluetooth-applet from the command
  line and it should be working again.

  It's not the end of the world, but Audacity should be configured to
  work properly in the default environment.

  I suggest eliminating Alsa and bluetooth support and have it not try
  to fight proper daemons handle it as they do a much better job. At
  least with PA and Bluetooth. I don't know how well Jack supports
  bluetooth audio devices, but Audacity really should not be allowed to
  do this sort of thing. I understand that it seems like a nice feature
  to be able to use a headset outside of Gnome, but it seems to be
  fundamentally incompatible with having a bluetooth adapter that is
  able to work with any other device.

  For people that may run into this problem in the future through Google or 
whatever here is two work arounds I suggest:

  1. Remove or otherwise disable all your bluetooth radio prior to
  attempting to run Audacity.

  2. If you forget to do that and Audacity breaks your ability to use
  bluetooth then remove the bluetooth audio device from your computer,
  plug it back in, and either log out/log in or start bluetooth-applet
  manually from the command line or 'alt-f2'. If your using internal
  bluetooth then try turning it off and on. If that fails then you will
  be forced to reboot.

  Thank you for your time and your patience.  Keep in mind that as long
  as this bug exists you will probably have people complaining that
  either Audacity won't launch or will try to file bug reports against
  the kernel or bluetooth support in Gnome. It's not obvious that this
  problem is caused by Audacity's bluetooth support unless you run it
  from the command line. So most people are probably not going to make a
  connection that one is breaking the other.  If your lucky you might be
  able to wipe out a couple other bug reports.

  Information on what I have installed:

  $ dpkg -S `which audacity`
  audacity: /usr/bin/audacity

  $ dpkg-query -s  audacity
  Package: audacity
  Status: install ok installed
  Priority: optional
  Section: sound
  Installed-Size: 7376
  Maintainer: Ubuntu Developers <>
  Architecture: amd64
  Version: 1.3.12-7

  $ lsusb|grep -i blue
  Bus 006 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth 
Dongle (HCI mode)

  $ uname -a
  Linux ubunturox 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 11:55:36 UTC 2010 
x86_64 GNU/Linux

  $ lsb_release -rd
  Description:  Ubuntu 10.10
  Release:      10.10

  What I expected to happen:
  Open Audacity to edit a file for a ringtone. Make a quick edit, save the 
file, upload to the phone via bluetooth

  What happened instead:
  Audacity hung 2 or 3 times and finally opened. Made a quick edit to a mp3 
file for a ringtone. Tried to upload the file to the phone via nautilus 'send 
to' support, and eventually realized that Audacity broke it.

  A final suggestion for Ubuntu:
  I don't know how to do it but applications should have all Alsa access 
disabled except through PA. None of these apps should have access to hardware 
to do things like this... they should go through services provided by the 
desktop. I have a sinking suspicion that Ekiga is another application that is 
breaking my hardware by trying to be too clever. I have a USB headset and 
Bluetooth headset that have been screwed up by my Linux laptop. They worked 
fine out of the box with no configuration and no effort. Everything was able to 
read from their microphones and play music and audio through them via 
PulseAudio, however after playing around with SIP both developed bad 
configuration problems. Keep in mind that I used them both for a very long time 
and the only thing that I can think they had in common was that I struggled to 
get Ekiga working with the microphone due to it's lack of proper audio 
configuration support. I think that it went and tried to 'optimize' things to 
make the microphon
 e work, but ended up doing weird things by using low-level alsa features in 
unusual ways. I don't know this for a fact and I can't reproduce it, so filing 
a bug is probably a waste of my time. I was able to recover my bluetooth 
headset back into a working configuration after letting it's battery drain, but 
I still can't get my USB headset working again (it seems to be stuck into weird 
in-between mode between stereo and mono. Stereo sounds play find, but sounds 
that come out equally in both left and right seem to cancel each other out and 
are very quiet and echo-y).  

  Again, thank you for taking the time to read this. Linux audio has
  come a long long way from the days of having to grep through
  /proc/asound files to find the proper values to put into my dmix
  asoundrc configuration to make movie playback non-suck.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to