On 07/11/2011 08:39 PM, Mike Frysinger wrote:
On Friday, July 01, 2011 17:50:15 Khem Raj wrote:
--- a/include/sys/signalfd.h
+++ b/include/sys/signalfd.h
@@ -64,6 +64,15 @@ enum
  # define SFD_NONBLOCK SFD_NONBLOCK
    };

+#elif defined __mips__
+enum
+  {
+    SFD_CLOEXEC = 02000000,
+# define SFD_CLOEXEC SFD_CLOEXEC
+    SFD_NONBLOCK = 0200
+# define SFD_NONBLOCK SFD_NONBLOCK
+  };

seems like this would be better as a bits/signalfd.h rather than inlining arch
ifdef checks all over the place

there is tendency to consolidate headers thats why its like this. Initially I wondered too

-mike



_______________________________________________
uClibc mailing list
[email protected]
http://lists.busybox.net/mailman/listinfo/uclibc

_______________________________________________
uClibc mailing list
[email protected]
http://lists.busybox.net/mailman/listinfo/uclibc

Reply via email to