Window 10, LC 8.1.9, Trying to compile a standalone with more than just one
application file to the main file (mainfile = splash screen stack).

I have a problem and working on this for many hours now. I am using a
splash stack as the "main stack" for compilation and I am including the
application stack using the dialogs in the "Stacks" pane of the "Standalone
Application Settings" window.

When I add this one application stack file all is fine. It compiles.

Now I want to add a library stack using the same "Stacks" pane just adding
this other stack to the same subfolder "resources" which also contains the
app file.

Compilation completely fails when adding this library stack (or any other
stack file I tested). During such compile, only the resources folder is
created and one of the included stacks is placed in there. Then the
compilation process quits without error.

I tried everything I could imagine to find out what is going wrong. Maybe
there is some script error in the application file or the splash stack. But
I have no idea as it all works in the IDE and it works in the limited
setting just using this one app file. An also in debugging mode nothing can
be detected. But somehow LiveCode does not like any additional brother or
sister for my application file.

When I do this with completely independent stack files it works though. I
made some test stacks to find out whether is a general problem. But
there... all is ok.

Maybe someone had similar experiences?

How can we check what is going wrong during compilation?

I am at the end of my wisdom. Sigh.

use-livecode mailing list
Please visit this url to subscribe, unsubscribe and manage your subscription 

Reply via email to