Some of my client's stacks must begin with names starting with "rev" (i.e., Bible study, "Revelations".) This of course wreaks havoc in the IDE, aside from just omitting the stacks from file lists. We have tried setting gRevDevelopment to true and turning on the option to view IDE stacks, but lots of other things still fail. Objects can't be selected with the edit tool and other oddities occur that make the stacks uneditable.

Temporarily renaming the stack sometimes works, but throws errors all over the place when scripts try to navigate or use the long ID for other purposes.

But now something else is occuring, totally unintelligible. Normally two stacks are open, an index stack "TSMain" and a mainstack "Revelations". When trying to navigate to Revelations by any method -- opening it from Finder, clicking the name in the index stack, etc. -- this error is thrown:

"A stack with the same name as the one you are trying to load is already open. Before loading /Users/<name>/Documents/<product>/Revelations.livecode what do you want to do with stack
 /Users/<name>/Documents/<product>/TSMain.livecode, TSMain?"

Besides the issue that the two "conflicting" stacks do not have the same name, the TSMain stack is listed twice, once as a full file path followed by the short name.

Huh? This is under LC 9.0.1 but also happens in LC 8.

How would you manage working with a stack whose name starts with "rev"? We are planning to change the name somehow if we can think of a good substitute, but for now it needs to stay as-is. And what's the deal with the weird conflict message? There are no duplicate stacks in RAM.

Jacqueline Landman Gay         |
HyperActive Software           |

use-livecode mailing list
Please visit this url to subscribe, unsubscribe and manage your subscription 

Reply via email to