Thanks Doroszlai.
ambari-server.log has below exception. Why it tries to find a redhat7? I am
using oracle linux 7 which is supported by ambari.
java.lang.RuntimeException:
org.apache.ambari.server.controller.spi.SystemException: Operating System
matching redhat7 could not be found
at
org.apache.ambari.server.actionmanager.ExecutionCommandWrapper.getExecutionCommand(ExecutionCommandWrapper.java:253)
at
org.apache.ambari.server.actionmanager.ActionScheduler.processInProgressStage(ActionScheduler.java:704)
at
org.apache.ambari.server.actionmanager.ActionScheduler.doWork(ActionScheduler.java:417)
at
org.apache.ambari.server.actionmanager.ActionScheduler.run(ActionScheduler.java:310)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.ambari.server.controller.spi.SystemException:
Operating System matching redhat7 could not be found
at
org.apache.ambari.server.state.stack.upgrade.RepositoryVersionHelper.getOSEntityForHost(RepositoryVersionHelper.java:422)
at
org.apache.ambari.server.actionmanager.ExecutionCommandWrapper.getExecutionCommand(ExecutionCommandWrapper.java:247)
... 4 more
Thanks for any clue.
On Tue, Feb 6, 2018 at 10:08 AM, Doroszlai, Attila <[email protected]>
wrote:
> Hi Lian,
>
> Please take a look at /var/log/ambari-server/ambari-server.log, it
> will likely have some information about the problem. It may be
> waiting for agents to join, or it may have some misconfiguration that
> it failed to detect when the blueprint and cluster were submitted,
> etc.
>
> The fact that it is stuck at PENDING "forever" is a bug that's fixed
> in https://issues.apache.org/jira/browse/AMBARI-22805
>
> -Attila
>
> On Tue, Feb 6, 2018 at 6:51 PM, Lian Jiang <[email protected]> wrote:
> > Hi,
> >
> > I am following
> > https://cwiki.apache.org/confluence/display/AMBARI/
> Blueprints#Blueprints-ExampleBlueprint.1
> > to create a two nodes cluster using blueprint and a cluster template.
> >
> > After submitting cluster creation request, the status stuck at:
> >
> > "href" : "http://localhost:8080/api/v1/clusters/mycluster/requests/1",
> >
> > "Requests" : {
> >
> > "aborted_task_count" : 0,
> >
> > "cluster_host_info" : "{}",
> >
> > "cluster_name" : "mycluster",
> >
> > "completed_task_count" : 0,
> >
> > "create_time" : 1517937973997,
> >
> > "end_time" : -1,
> >
> > "exclusive" : false,
> >
> > "failed_task_count" : 0,
> >
> > "id" : 1,
> >
> > "inputs" : null,
> >
> > "operation_level" : null,
> >
> > "pending_host_request_count" : 0,
> >
> > "progress_percent" : 0.0,
> >
> > "queued_task_count" : 0,
> >
> > "request_context" : "Logical Request: Provision Cluster 'mycluster'",
> >
> > "request_schedule" : null,
> >
> > "request_status" : "PENDING",
> >
> > "resource_filters" : null,
> >
> > "start_time" : -1,
> >
> > "task_count" : 20,
> >
> > "timed_out_task_count" : 0,
> >
> > "type" : null
> >
> > },
> >
> >
> > As you can see, the tasks are not scheduled. I am using horton ambari
> > 2.6.1.0. Any idea how to debug this issue? Appreciate any help!
> >
> >
>