Hi all,

        FYI, I am also posting this on SO.

I'm really not sure where the issue lies with this problem, whether it's a Nutch problem, Kibana or Elasticsearch. I'm using Nutch 2.3, HBase 0.94.14 and Elasticsearch 1.6 with Kibana 4.1.0 to crawl, archive and index.

I primarily followed the following tutorial, with the only exception being the upgrade to ES 1.6 from the tutorial's version of 1.4 (which I am now wondering if that's a problem).


        Following this tutorial, I am using the /bin/nutch script.

Most everything works; Nutch follows my seed URL's, HBase stores the downloads and Elasticsearch seems to be indexing the content, however I can't get Kibana to visualize the content coming from Nutch. Kibana recognizes the index and its fields, however shows no content. I've loaded the index in Kibana with and without time-based events to no avail.

I have other indexes and 'types' in that Elasticsearch instance which Kibana can visualize AND I can query Elasticsearch with cURL and get the nutch results just fine, I just can't get Kibana to visualize the specific content from Nutch.

I've tried two different ES + Kibana setups and just redirected the Nutch indexing output and am having the same problem on both. I have also tried deleting the index and starting over, creating the index first and then running 'nutch index -all' and trying a clean Elasticsearch / Kibana install.

My guess is there is something about the different in the ES version, though if there were a problem with that, wouldn't the Transport Client simply fail on inserting?

Any help would be appreciated, do I need to upgrade the Indexer to match the Elasticsearch version?


Brooks Isoldi, Software Developer

7164 Columbia Gateway Drive, Suite 120A
Columbia, MD 21046

Reply via email to