I wonder if this was an intentional change: My mapping config looks like this:
<resultMap id="partSetMap" type="PartSetDto"> <id property="id" column="id"/> <collection property="parts" ofType=" PartDto"> <result column="part_id" property="id" javaType="Long"/> <result column="serial_no" property="serialNo" javaType="String"/> <result column="is_reserved" property="isReserved" javaType="boolean"/> </collection> </resultMap> <select id="selectPage" resultMap="partSetMap"> ... PartSetDto has lots of other properties than "id". In beta 8 those were automatically filled by naming convention. In beta 9 all other fields are empty.