Hi Pablo -

Thanks for the quick response.
Here's my pom.xml

<project xmlns="http://maven.apache.org/POM/4.0.0"; xmlns:xsi="
http://www.w3.org/2001/XMLSchema-instance";

  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd";>

  <modelVersion>4.0.0</modelVersion>


  <groupId>com.mvangala.beam</groupId>

  <artifactId>hello-world</artifactId>

  <version>0.0.1-SNAPSHOT</version>

  <packaging>jar</packaging>


  <name>hello-world</name>

  <url>http://maven.apache.org</url>


  <properties>

    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>

  </properties>


  <dependencies>

    <dependency>

      <groupId>junit</groupId>

      <artifactId>junit</artifactId>

      <version>3.8.1</version>

      <scope>test</scope>

    </dependency>

    <!-- https://mvnrepository.com/artifact/org.slf4j/slf4j-api -->

<dependency>

      <groupId>org.slf4j</groupId>

      <artifactId>slf4j-api</artifactId>

      <version>1.7.25</version>

</dependency>

<dependency>

      <groupId>org.slf4j</groupId>

      <artifactId>slf4j-simple</artifactId>

      <version>1.7.25</version>

    </dependency>

    <!--
https://mvnrepository.com/artifact/org.apache.beam/beam-sdks-java-core -->

<dependency>

      <groupId>org.apache.beam</groupId>

      <artifactId>beam-sdks-java-core</artifactId>

      <version>2.6.0</version>

</dependency>

    <!--
https://mvnrepository.com/artifact/org.apache.beam/beam-runners-direct-java
-->

<dependency>

      <groupId>org.apache.beam</groupId>

      <artifactId>beam-runners-direct-java</artifactId>

      <version>2.6.0</version>

      <scope>runtime</scope>

</dependency>

<!-- https://mvnrepository.com/artifact/com.google.protobuf/protobuf-java
-->

<dependency>

      <groupId>com.google.protobuf</groupId>

      <artifactId>protobuf-java</artifactId>

      <version>2.6.1</version>

</dependency>

  </dependencies>

</project>


Thank you,
Mahesh

On Sat, Aug 11, 2018 at 6:49 PM Pablo Estrada <pabl...@google.com> wrote:

> Can you elaborate on your setup? Are you using a Maven archetype? Did you
> hand-write a pom.xml? Are you installing from code with gradle?
> Best
> -P.
>
> On Sat, Aug 11, 2018, 3:43 PM Mahesh Vangala <vangalamahe...@gmail.com>
> wrote:
>
>> Hello folks -
>>
>> I am enthusiastic about learning beam using java sdk.
>> I set up maven using eclipse today.
>> However, I ran into the following error message:
>>
>> Caused by: java.lang.ClassNotFoundException:
>> org.apache.beam.vendor.protobuf.v3.com.google.protobuf.ProtocolMessageEnum
>>
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
>>
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
>>
>> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:338)
>>
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
>>
>> ... 12 more
>>
>>
>> Any help from the team is appreciated!
>> Thanks.
>>
>> - Mahesh
>>
> --
> Got feedback? go/pabloem-feedback
>

Reply via email to