Hi Aljoscha,

Thanks for your response. By the first time I mean I hit run from the IDE
(I am using Netbeans on Windows) the first time after building the program.
If then I stop it and run it again (without rebuidling) It is stuck in the
state RUNNING. Sometimes I have to rebuild it, or close the IDE to be able
to get an output. The behaviour is random, maybe it's related to the IDE or
the OS and not necessarily Flink itself.

On Sep 17, 2016 15:16, "Aljoscha Krettek" <aljos...@apache.org> wrote:

> Hi,
> when is the "first time". It seems you have tried this repeatedly so what
> differentiates a "first time" from the other times? Are you closing your
> IDE in-between or do you mean running the job a second time within the same
> program?
> Cheers,
> Aljoscha
> On Fri, 9 Sep 2016 at 16:40 Yassine MARZOUGUI <y.marzou...@mindlytix.com>
> wrote:
>> Hi all,
>> When I run the following batch job inside the IDE for the first time, it
>> outputs results and switches to FINISHED, but when I run it again it is
>> stuck in the state RUNNING. The csv file size is 160 MB. What could be the
>> reason for this behaviour?
>> public class BatchJob {
>>     public static void main(String[] args) throws Exception {
>>         final ExecutionEnvironment env = ExecutionEnvironment.
>> getExecutionEnvironment();
>>         env.readCsvFile("dump.csv")
>>                 .ignoreFirstLine()
>>                 .fieldDelimiter(";")
>>                 .includeFields("111000")
>>                 .types(String.class, String.class, String.class)
>>                 .first(100)
>>                 .print();
>>     }
>> }
>> Best,
>> Yassine

Reply via email to