Thank you, it worked, but there was another problem now in same example.

How to use .filter():

val table = tEnv
.filter('name.isNotNull && 'last_update > "2016-01-01 00:00:00".toTimestamp)
.select('id, 'name.lowerCase(), 'prefs)

Error in compiling: "Value > is not member of Symbol"

Is that syntactically correct, may it be problem with "imports" or is it 
deprecated ?

Best, Esa

From: Timo Walther [mailto:twal...@apache.org]
Sent: Monday, March 5, 2018 3:15 PM
To: user@flink.apache.org
Subject: Re: CsvTableSource Types.TIMESTAMP


SQL_TIMESTAMP is the same. A couple of months ago it was decided to rename this 
property such that it can be used for timestamps with timezone support in the 


Am 3/5/18 um 2:10 PM schrieb Esa Heikkinen:
I have tried to following example to work, but no succeed yet.


Error .. value TIMESTAMP is not a member of object 

What would be the problem ?

What the imports should I use ?

Or should I use SQL_TIMESTAMP instead of it ? is it same ?

Best, Esa

Reply via email to