CVE-2017-15692 Apache Geode unsafe deserialization in TcpServer

Severity:  Important

Vendor: The Apache Software Foundation

Versions Affected:  Apache Geode 1.0.0 through 1.3.0

The TcpServer within the Geode locator opens a network port that
deserializes data.  If an unprivileged user gains access to the Geode
locator, they may be able to cause remote code execution if certain
classes are present on the classpath.

A malicious user can send a network message to the Geode locator and
execute code if certain classes are present on the classpath.

Users of the affected versions should upgrade to Apache Geode 1.4.0 or
later.  In addition, users should set the flag

This issue was reported responsibly to the Apache Geode Security Team
by Man Yue Mo from Semmle.


Reply via email to