Hi Jorge ,

you are saying "soon after giving the timeout error if I click on
reconnect, the connection will normally no problem"

i would suggest you to capture the packets using tcpdump command for both
the cases from Ubuntu server and analyse , then you will get to know where
it is failing  .

tcpdump -nX -s0 -i any host XX.XXX.XX.XX and port 22/3389 .

if you want to save and analyse in wireshark , use the below command

tcpdump -nX -s0 -i any host XX.XXX.XX.XX and port 22/3389 -w /tmp/1.pcap


also you to can do  continues check (telnet or check_tcp ) the port (22 or
3389) from this guacamole machine .

i hope this will help you  .



On Thu, Feb 16, 2017 at 3:45 PM, Jorge Camara <jorge.cam...@webaula.com>
wrote:

> We have no proxy on the network. And the antivirus on my machine is turned
> off.
> And as I said, soon after giving the timeout error if I click on
> reconnect, the connection will normally no problem.
>
> It is a fresh installation of the ubuntu server on Virtual Machine and
> guacamole. All servers are all from the same network as well.
>
> I also tried to use the browser in anonymous mode but it has the same
> effect. Linux server also has no active firewall.
>
> Maybe some parameter on the linux server I've gone unnoticed, or something
> else.
>
> My intention to use Guacamole is only to record the remote connections for
> audit purposes.
>
> If you have something else that I can clarify please let me know.
>
> Thanks
>
> Jorge Camara
>
>
>
> 2017-02-16 0:56 GMT-02:00 Mike Jumper <mike.jum...@guac-dev.org>:
>
>> As both guacd and the web application are reporting that the other is not
>> responding, the most likely explanation from my experience would be:
>>
>> 1) There is something on the network between the browser and the
>> Guacamole server which is eating/buffering the data stream (such as a proxy
>> or certain virus scanning software)
>> 2) guacd is waiting for a response from the client before sending further
>> data
>> 3) With the client waiting for guacd, and guacd waiting for the client,
>> both timeout at the same time.
>>
>> Do you know if there might be a proxy between the browser in question and
>> the Guacamole server?
>>
>> - Mike
>>
>>
>> On Wed, Feb 15, 2017 at 9:46 AM, Jorge Camara <jorge.cam...@webaula.com>
>> wrote:
>>
>>> Hi  people.
>>>
>>> I did not receive any response and would appreciate it if I had.
>>> I would also like to know if anyone has at least been through this.
>>>
>>> Best Regards.
>>> Jorge
>>>
>>>
>>>
>>> 2017-02-06 10:08 GMT-02:00 Jorge Camara <jorge.cam...@webaula.com>:
>>>
>>>> Hi,
>>>>
>>>> I made a new install of Ubuntu 16.04.1 LTS and Guacamole
>>>> 0.9.11-incubating released on February 3rd.
>>>>
>>>> Since the last version, I have occasionally had trouble connecting to
>>>> some servers at random.
>>>>
>>>> An example is as we can see below. I clicked to connect to a server and
>>>> it stays in this screen:
>>>>
>>>>
>>>> [image: Imagem inline 1]
>>>>
>>>> After a while this screen appears:
>>>>
>>>> [image: Imagem inline 2]
>>>>
>>>>
>>>> If I click on "reconnect" the connection will go normally. But if I
>>>> wait a few minutes and try to reconnect to the same server, the same
>>>> problems happen again.
>>>>
>>>> Below is the output of the guacd log in debug mode and tomcat8.
>>>>
>>>> I'm just using tomcat8, with mysql. Apache or nginx is not installed.
>>>>
>>>>
>>>>
>>>> Output of /var/log/syslog:
>>>>
>>>> Feb  6 09:40:41 ubuntuimg guacd[395]: Creating new client for protocol
>>>> "rdp"
>>>> Feb  6 09:40:41 ubuntuimg guacd[395]: Connection ID is
>>>> "$5dd567e7-f7f0-4011-8c6a-c442d45266e3"
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "console" omitted.
>>>> Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "console-audio"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "ignore-cert" omitted.
>>>> Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "disable-auth" omitted.
>>>> Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: No security mode specified.
>>>> Defaulting to RDP.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: User resolution is 1440x804 at 96
>>>> DPI
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "dpi" omitted. Using
>>>> default value of 96.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Using resolution of 1440x804 at
>>>> 96 DPI
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "read-only" omitted.
>>>> Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-wallpaper"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-theming"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-font-smoothing"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter
>>>> "enable-full-window-drag" omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter
>>>> "enable-desktop-composition" omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter
>>>> "enable-menu-animations" omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "color-depth" omitted.
>>>> Using default value of 16.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "disable-audio"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-printing"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-drive" omitted.
>>>> Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "drive-path" omitted.
>>>> Using default value of "".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "create-drive-path"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-sftp" omitted.
>>>> Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "sftp-hostname"
>>>> omitted. Using default value of "wadc02.webaula.dc".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "sftp-port" omitted.
>>>> Using default value of "22".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "sftp-username"
>>>> omitted. Using default value of "".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "sftp-password"
>>>> omitted. Using default value of "".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "sftp-passphrase"
>>>> omitted. Using default value of "".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Resize method: none
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Parameter "enable-audio-input"
>>>> omitted. Using default value of 0.
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: User
>>>> "@3f701d9c-192d-4f76-aa82-dbe1fee96e31" joined connection
>>>> "$5dd567e7-f7f0-4011-8c6a-c442d45266e3" (1 users now present)
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Recording of session will be
>>>> saved to "/etc/guacamole/rec//wadc02.11".
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Loading keymap "base"
>>>> Feb  6 09:40:41 ubuntuimg guacd[408]: Loading keymap "en-us-qwerty"
>>>> Feb  6 09:41:11 ubuntuimg guacd[408]: User is not responding.
>>>> Feb  6 09:41:11 ubuntuimg guacd[408]: User
>>>> "@3f701d9c-192d-4f76-aa82-dbe1fee96e31" disconnected (0 users remain)
>>>> Feb  6 09:41:11 ubuntuimg guacd[408]: Last user of connection
>>>> "$5dd567e7-f7f0-4011-8c6a-c442d45266e3" disconnected
>>>>
>>>>
>>>> Output /var/log/tomcat8/catalina.out
>>>>
>>>> 09:40:41.223 [http-nio-8080-exec-9] INFO  o.a.g.tunnel.TunnelRequestService
>>>> - User "jorge" connected to connection "2".
>>>> 09:40:56.272 [Thread-45] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint
>>>> - Connection to guacd terminated abnormally: Connection to guacd timed out.
>>>> 09:40:56.276 [Thread-45] INFO  o.a.g.tunnel.TunnelRequestService -
>>>> User "jorge" disconnected from connection "2". Duration: 15052 milliseconds
>>>>
>>>>
>>>> I look forward to some help, and available for any questions.
>>>>
>>>>
>>>>
>>
>

Reply via email to