Hi Larry - Thanks a lot for getting back to me.

Yes I made sure all DEBUG level is turned off in my gateway-log4j.properties
file, but that doesn't seem to be working. I also tried to explicitly set
log4j.logger.httpclient.wire.header to WARN (as suggested in post
<https://stackoverflow.com/questions/4915414/disable-httpclient-logging>),
but that also didn't help.

Actually it's very easy to reproduce this(at least on my side). If you call
knox with a webhdfs request (like webhdfs/v1/tmp/weihan/small.txt?op=OPEN),
you should be able to see a bunch of below logs in gateway.out. In fact it
outputs the actual content on the wire(security hole?)

      06:52:49.751 [qtp1473205473-61] DEBUG org.apache.http.wire -
http-outgoing-2 << "[0x0][0x0

Let me know if you're able to repro this.

Thanks.

On Sat, Apr 14, 2018 at 7:11 AM, larry mccay <lmc...@apache.org> wrote:

> Hi Wei -
>
> If you look at your gateway-log4j.properties file, you should see
> something like the following near the top:
>
> app.log.dir=${launcher.dir}/../logs
> app.log.file=${launcher.name}.log
> app.audit.file=${launcher.name}-audit.log
>
> log4j.rootLogger=ERROR, drfa
>
> log4j.logger.org.apache.knox.gateway=INFO
> #log4j.logger.org.apache.knox.gateway=DEBUG
>
> #log4j.logger.org.eclipse.jetty=DEBUG
> #log4j.logger.org.apache.shiro=DEBUG
> #log4j.logger.org.apache.http=DEBUG
> #log4j.logger.org.apache.http.client=DEBUG
> #log4j.logger.org.apache.http.headers=DEBUG
> #log4j.logger.org.apache.http.wire=DEBUG
>
> Note that all of the DEBUG settings are commented out.
> Also note that the rootLogger is set to ERROR and not DEBUG.
>
> Can you compare and share with us what yours are set to?
>
> thanks,
>
> --larry
>
> On Sat, Apr 14, 2018 at 2:56 AM, Wei Han <wei...@uber.com> wrote:
>
>> Hi Knox experts -
>>
>> Has anyone successfully turn off the debug loggings
>> from org.apache.http.wire, like below?
>>
>>       06:52:49.751 [qtp1473205473-61] DEBUG org.apache.http.wire -
>> http-outgoing-2 << "[0x0][0x0
>>
>> I've tried almost everything in this stackoverflow post
>> <https://stackoverflow.com/questions/4915414/disable-httpclient-logging>,
>> but my gateway.out is still filled with all the debug logs from httpclient.
>>
>> Any tip would be appreciated.
>>
>
>

Reply via email to