Hello,

I would like to suggest that the next release of MADlib be called v1.10.
Recently I have been referring to it as v1.9.2.

However, MADlib follows 3-digit semantic versioning MAJOR.MINOR.PATCH
http://semver.org/
where:

* MAJOR version when you make incompatible API changes,
* MINOR version when you add functionality in a backwards-compatible
manner, and
* PATCH version when you make backwards-compatible bug fixes.

Since the next release will add functionality, it should be MINOR.

I actually made a mistake in naming v1.9.1 since it added functionality but
was versioned as if it was a PATCH, which it wasn’t.

I'll update the JIRAs and wiki unless anyone has an objection.

Frank

Reply via email to