I upgraded my project from mesos 1.4.1 + jdk 8 + spark 2.3.1 + CentOS7 to use 
mesos 1.9.0 and jdk headless 11 in RHEL7 with spark 3.0.0.  I am getting the 
following "Failed to load class" error I0807 16:47:34.699182 21059 
executor.cpp:190] Received LAUNCH eventI0807 16:47:34.699383 21059 
executor.cpp:722] Starting task driver-20200807164731-0014I0807 16:47:34.705006 
21059 executor.cpp:738] Forked command at 21068WARNING: An illegal reflective 
access operation has occurredWARNING: Illegal reflective access by 
 to constructor java.nio.DirectByteBuffer(long,int)WARNING: Please consider 
reporting this to the maintainers of org.apache.spark.unsafe.PlatformWARNING: 
Use --illegal-access=warn to enable warnings of further illegal reflective 
access operationsWARNING: All illegal access operations will be denied in a 
future releaseError: Failed to load class 
org.apache.spark.examples.SparkPi.I0807 16:47:37.503019 21059 
executor.cpp:1039] Command exited with status 101 (pid: 21068)I0807 
16:47:38.504026 21067 process.cpp:935] Stopped the socket accept loop
I got this error with our product jar and so I tried to use the example jar 
that came with spark and got the same error as well.I noticed that with the 
previous mesos version 1.4.1, the downloaded extracted spark folder has uid=501 
and gid=games.  After the upgrade, the dowloaded spark folder has uid=root and 
gid=root.  Will that has anything to do with the "Failed to load class... 
status 101" failure?  Both the jar and the spark folder was downloaded 
successfully.  I can execute the downloaded jars locally but mesos cannot load 
the class.
Mesos was installed using the mesos-1.9.0-1.el7.x86_64.rpm

Reply via email to