Just to wrap this up. I've tried to deploy it on HDP 2.5 but I got the exact
same problem. What I did was removing all components for and then
created a new cluster based on 2.5. I left it at that as the most likely
issue could be with my base install. May that be wrong version of something
or even a missing dev package.

As my work also coincided with the announcement by Casey I went ahead
and installed
0.3.0 as a dev installation instead. That worked great as the dev-full-platform
guide is very complete.

As a general feedback, in order to get more people interested and not having
noobs like me come up with redundant questions - At this stage also sorry
for not providing a meaningful subject, I simply was too excited :)

There is much to win with a small extension of the installation guide. I don't
think it needs much more prose around but a full package version dump with
every new release would help greatly to get things going. For the things
which need to be compiled in, the versioning information should be enough.
I am saying this, as everyone starts with a different base system. Some
have the chance to start from scratch, some have a system running and build
something on top and then there are the experienced Metron users, who have
many base requirements.. they tend to forget. And I believe at the end
it always fails just because of some very tiny small difference.

If there is a space somewhere available, this could even be a spot,
where people
can say, "hey, I got this running on XYZ and here is the package version
dump". A simple table with 'Metron version', 'OS release', 'Package list
file', 'Version Details of every other needed to-be-compiled package', is
already a big help. This really could supplement the existing guide found
here: https://cwiki.apache.org/confluence/display/METRON/

But then, I could be alone and others did not experience the same and simply
got it to run, I don't know. Anyway, I would be happy to help if help is


On Sun, Nov 27, 2016 at 3:00 PM, shoggi <sho...@gmail.com> wrote:

> Hi Simon
> Thank you for your very quick response. I installed it on HDP
> I had a 0.2.0 instance running and was very conscious about versioning the
> various components. Somehow I had the understanding of not touching 2.5 as
> of yet. I give that a try.
> Thanks heaps !
> Shoggi
> On Sun, Nov 27, 2016 at 2:52 PM, Simon Elliston Ball <
> si...@simonellistonball.com> wrote:
>> Hi Shoggi,
>> Can I ask which version of HDP you used as a base. The article is a
>> little out of date in that is calls for 2.4, which the 0.3.0 release is
>> based on 2.5. There was a major version difference in storm between the
>> two, which seems likely to have caused the problem you're seeing.
>> Simon
>> Sent from my iPad
>> On 27 Nov 2016, at 13:48, shoggi <sho...@gmail.com> wrote:
>> Hi all
>> I followed the installation guide to deploy Metron via Ambari
>> https://community.hortonworks.com/articles/60805/
>> deploying-a-fresh-metron-cluster-using-ambari-serv.html.
>> I ended up with all but the Metron Components (Enrichment, Parsing,
>> Parsers) to start up. The closest to pinpoint the issue is, when I try to
>> start any new parser topology such as with bro:
>> /usr/metron/0.3.0/bin/start_parser_topology.sh -k x.localdomain:6667 -z
>> x.localdomain:2181 -s bro
>> The error I get is:
>> Exception in thread "main" java.lang.BootstrapMethodError:
>> java.lang.NoClassDefFoundError: org/apache/storm/Config
>> Or in more details:
>> Running: /usr/jdk64/jdk1.8.0_77/bin/java -client -Ddaemon.name=
>> -Dstorm.options= -Dstorm.home=/usr/hdp/
>> -Dstorm.log.dir=/var/log/storm -Djava.library.path=/usr/local
>> /lib:/opt/local/lib:/usr/lib:/usr/hdp/current/storm-client/lib
>> -Dstorm.conf.file= -cp /usr/hdp/
>> /asm-4.0.jar:/usr/hdp/
>> jar:/usr/hdp/
>> /usr/hdp/
>> hdp/
>> 0-227/storm/lib/clout-1.0.1.jar:/usr/hdp/
>> /lib/commons-codec-1.6.jar:/usr/hdp/
>> compojure-1.1.3.jar:/usr/hdp/
>> incubator-0.1.0.jar:/usr/hdp/
>> r-2.10.1.jar:/usr/hdp/
>> jar:/usr/hdp/
>> 4.3.0-227.jar:/usr/hdp/
>> jar:/usr/hdp/
>> 0-227/storm/lib/jackson-dataformat-smile-2.3.1.jar:/usr/hdp/2.4.
>> 3.0-227/storm/lib/java.classpath-0.2.2.jar:/usr/hdp/
>> jar:/usr/hdp/
>> usr/hdp/
>> 0-227/storm/lib/log4j-api-2.1.jar:/usr/hdp/
>> storm/lib/log4j-core-2.1.jar:/usr/hdp/
>> log4j-over-slf4j-1.6.6.jar:/usr/hdp/
>> log4j-slf4j-impl-2.1.jar:/usr/hdp/
>> minlog-1.2.jar:/usr/hdp/
>> 2.2.jar:/usr/hdp/
>> usr/hdp/
>> usr/hdp/
>> 3.0-227/storm/lib/ring-jetty-adapter-1.3.0.jar:/usr/hdp/2.
>> 4.3.0-227/storm/lib/ring-json-0.3.1.jar:/usr/hdp/
>> 227/storm/lib/ring-servlet-1.3.0.jar:/usr/hdp/
>> torm/lib/servlet-api-2.5.jar:/usr/hdp/
>> slf4j-api-1.7.7.jar:/usr/hdp/
>> core-
>> tigris-0.1.1.jar:/usr/hdp/
>> logging-0.2.3.jar:/usr/hdp/
>> namespace-0.2.4.jar:/usr/hdp/
>> r.jar:/usr/metron/0.3.0/lib/metron-parsers-0.3.0-uber.jar:
>> /usr/hdp/current/storm-supervisor/conf:/usr/hdp/
>> -Dstorm.jar=/usr/metron/0.3.0/lib/metron-parsers-0.3.0-uber.jar
>> org.apache.metron.parsers.topology.ParserTopologyCLI -k
>> x.localdomain:6667 -z x.localdomain:2181 -s bro
>> Exception in thread "main" java.lang.BootstrapMethodError:
>> java.lang.NoClassDefFoundError: org/apache/storm/Config
>> at org.apache.metron.parsers.topology.ParserTopologyCLI$ParserO
>> ptions.<init>(ParserTopologyCLI.java:199)
>> at org.apache.metron.parsers.topology.ParserTopologyCLI$ParserO
>> ptions.<clinit>(ParserTopologyCLI.java:47)
>> at org.apache.metron.parsers.topology.ParserTopologyCLI.main(
>> ParserTopologyCLI.java:266)
>> Caused by: java.lang.NoClassDefFoundError: org/apache/storm/Config
>> ... 3 more
>> Caused by: java.lang.ClassNotFoundException: org.apache.storm.Config
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
>> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
>> ... 3 more
>> Must be something wrong with my config, possibly I have overlooked
>> something but can't put my finger on it. Any help is appreciated.
>> Many thanks
>> Shoggi
  • [no subject] shoggi
    • Re: Simon Elliston Ball
      • Re: shoggi
        • Re: shoggi
          • Re: Dima Kovalyov
            • Re: Tom James
            • Re: Otto Fowler
              • Re: Dima Kovalyov
                • Re: Otto Fowler
          • Re: Nick Allen
            • Re: zeo...@gmail.com
              • Re: Dima Kovalyov
                • Re: zeo...@gmail.com
                • Re: Dima Kovalyov

Reply via email to